summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/SGMLSpm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/SGMLSpm')
-rw-r--r--dev-perl/SGMLSpm/Manifest1
-rw-r--r--dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild25
-rw-r--r--dev-perl/SGMLSpm/files/Makefile.PL17
-rw-r--r--dev-perl/SGMLSpm/files/sgmlspl.patch11
-rw-r--r--dev-perl/SGMLSpm/metadata.xml16
5 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/SGMLSpm/Manifest b/dev-perl/SGMLSpm/Manifest
new file mode 100644
index 000000000000..81728dc55bc1
--- /dev/null
+++ b/dev-perl/SGMLSpm/Manifest
@@ -0,0 +1 @@
+DIST SGMLSpm-1.03ii.tar.gz 93250 SHA256 f06895c0206dada9f9e7f07ecaeb6a3651fd648f4820f49c1f76bfeaec2f2913 SHA512 edbac8112561912d5d7a9faee2d920bf763576ace5a9bdef5fc3f235533805643ad8db5f57d96c34ce9ecbf1796399dc531f40ab4b2796a1e130a8f288c901d4 WHIRLPOOL 9a08d394026aedc6b3c3634f590a9a9c4bbc406f22537c8126ed5b857e787c13a2ccbc295ee10bb6f3299b38099a281e0efa36ab6579cc9f98a96ea2f7849186
diff --git a/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
new file mode 100644
index 000000000000..1b4ac0a0dea4
--- /dev/null
+++ b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_P="${P}ii"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Perl library for parsing the output of nsgmls"
+HOMEPAGE="http://search.cpan.org/author/DMEGG/SGMLSpm-1.03ii/"
+SRC_URI="mirror://cpan/authors/id/D/DM/DMEGG/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile.PL "${S}"/Makefile.PL || die
+ epatch "${FILESDIR}"/sgmlspl.patch
+ mv sgmlspl{.pl,} || die
+}
diff --git a/dev-perl/SGMLSpm/files/Makefile.PL b/dev-perl/SGMLSpm/files/Makefile.PL
new file mode 100644
index 000000000000..a2508c0a9afb
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/Makefile.PL
@@ -0,0 +1,17 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'SGMLS',
+ 'VERSION' => '1.03ii',
+ 'PM' => { 'SGMLS.pm' => '$(INST_LIBDIR)/SGMLS.pm',
+ 'Output.pm' => '$(INST_LIBDIR)/SGMLS/Output.pm',
+ 'Refs.pm' => '$(INST_LIBDIR)/SGMLS/Refs.pm',
+ 'skel.pl' => '$(INST_LIBDIR)/sgmlspl-specs/skel.pl',
+ },
+ 'MAN3PODS'=> { 'SGMLS.pm' => '$(INST_MAN3DIR)/SGMLS.3pm',
+ 'Output.pm' => '$(INST_MAN3DIR)/SGMLS::Output.3pm',
+ 'Refs.pm' => '$(INST_MAN3DIR)/SGMLS::Refs.3pm',
+ },
+ 'EXE_FILES' => [ 'sgmlspl', ],
+);
diff --git a/dev-perl/SGMLSpm/files/sgmlspl.patch b/dev-perl/SGMLSpm/files/sgmlspl.patch
new file mode 100644
index 000000000000..946ce319a97d
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/sgmlspl.patch
@@ -0,0 +1,11 @@
+--- SGMLSpm/sgmlspl.pl.old 2008-08-23 17:06:13.000000000 +0200
++++ SGMLSpm/sgmlspl.pl 2008-08-23 17:07:13.000000000 +0200
+@@ -238,7 +238,7 @@
+ package main;
+
+ $ARGV = shift;
+-unless ($ARGV eq '' || do $ARGV) {
++unless ($ARGV eq '' || do 'sgmlspl-specs/' . $ARGV || do $ARGV) {
+ if (!-e $ARGV) {
+ die "FATAL: $ARGV does not exist.\n";
+ } elsif (!-r $ARGV) {
diff --git a/dev-perl/SGMLSpm/metadata.xml b/dev-perl/SGMLSpm/metadata.xml
new file mode 100644
index 000000000000..a15eb83580f1
--- /dev/null
+++ b/dev-perl/SGMLSpm/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">SGMLSpm</remote-id>
+ <remote-id type="cpan-module">SGMLS</remote-id>
+ <remote-id type="cpan-module">SGMLS::Output</remote-id>
+ <remote-id type="cpan-module">SGMLS::Refs</remote-id>
+ <remote-id type="cpan-module">SGMLS_Attribute</remote-id>
+ <remote-id type="cpan-module">SGMLS_Element</remote-id>
+ <remote-id type="cpan-module">SGMLS_Entity</remote-id>
+ <remote-id type="cpan-module">SGMLS_Event</remote-id>
+ <remote-id type="cpan-module">SGMLS_Notation</remote-id>
+ </upstream>
+</pkgmetadata>