summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Bit-Vector
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Bit-Vector')
-rw-r--r--dev-perl/Bit-Vector/Bit-Vector-7.200.0-r1.ebuild21
-rw-r--r--dev-perl/Bit-Vector/Bit-Vector-7.300.0.ebuild21
-rw-r--r--dev-perl/Bit-Vector/Bit-Vector-7.400.0.ebuild25
-rw-r--r--dev-perl/Bit-Vector/Manifest3
-rw-r--r--dev-perl/Bit-Vector/metadata.xml11
5 files changed, 81 insertions, 0 deletions
diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.200.0-r1.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.200.0-r1.ebuild
new file mode 100644
index 000000000000..ff2a0b2f5f88
--- /dev/null
+++ b/dev-perl/Bit-Vector/Bit-Vector-7.200.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ANDK
+MODULE_VERSION=7.2
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/Carp-Clan
+ >=virtual/perl-Storable-2.20"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.300.0.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.300.0.ebuild
new file mode 100644
index 000000000000..428f367411a7
--- /dev/null
+++ b/dev-perl/Bit-Vector/Bit-Vector-7.300.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=STBEY
+MODULE_VERSION=7.3
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/Carp-Clan
+ >=virtual/perl-Storable-2.20"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.400.0.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.400.0.ebuild
new file mode 100644
index 000000000000..5658aacae0ba
--- /dev/null
+++ b/dev-perl/Bit-Vector/Bit-Vector-7.400.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=STBEY
+MODULE_VERSION=7.4
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Carp-Clan-5.300.0
+ >=virtual/perl-Storable-2.210.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Bit-Vector/Manifest b/dev-perl/Bit-Vector/Manifest
new file mode 100644
index 000000000000..61dbbf1f48f9
--- /dev/null
+++ b/dev-perl/Bit-Vector/Manifest
@@ -0,0 +1,3 @@
+DIST Bit-Vector-7.2.tar.gz 137817 SHA256 6339f9e4376c623b411934cdfb52d7553c6c38457bfa376b953d40ca007807c2 SHA512 0344c2572e4a16259a4bb4b5f668c8f0ab32dc5a4eb0ab9e7da15ae86c1845036851095aa6353dcc9b1f9bf72ec5bd204e349c286ff5896869c36a4b7ff55955 WHIRLPOOL 219338151a816d055930878efe9c127f35ff3976c9e4c8a374bb821daace297fc6fee760d02b16225b5e7ceee45323a9b6ace0ef07a82ffb88d4f91e6d8bbd56
+DIST Bit-Vector-7.3.tar.gz 130395 SHA256 5a76330bfb9b9083371484c960d01ac0ad0e129fe770bfb1e87a85384e088f3d SHA512 e6baa2385d366ee00449abe52c20c49dbd41d2396d7c8f0fd6222262b6c4399d75eb081f46c5d1e524d12dafe0e5e78249f273e7705d04bd03033703fd2e86c8 WHIRLPOOL f583160f314e9d1ef0715711620ae5037e9cd196550c5f7ff2397ea4770a2d85b288d1d948619b2c724cb9bb8004a452493b340fcb1e491d7d67b649811e7503
+DIST Bit-Vector-7.4.tar.gz 135965 SHA256 3c6daa671fecfbc35f92a9385b563d65f50dfc6bdc8b4805f9ef46c0d035a926 SHA512 80aa49aea8c31c60c14161198eab9d620d738530c3c209104b8ad8f1144822f80c3effb3303c569fc556b2457328659ae5d1aaf511d714c835618b84c722abc5 WHIRLPOOL 2953d658f769e511522d11322793dd60f71b95e3ce6b4cc1ef0ff154f5889d53c8c4bb2ca66533398b400010da426292fbf69d6b1f2da7b50ce3ce5fa204a998
diff --git a/dev-perl/Bit-Vector/metadata.xml b/dev-perl/Bit-Vector/metadata.xml
new file mode 100644
index 000000000000..05325eca43cc
--- /dev/null
+++ b/dev-perl/Bit-Vector/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Bit-Vector</remote-id>
+ <remote-id type="cpan-module">Bit::Vector</remote-id>
+ <remote-id type="cpan-module">Bit::Vector::Overload</remote-id>
+ <remote-id type="cpan-module">Bit::Vector::String</remote-id>
+ </upstream>
+</pkgmetadata>