summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 14:04:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 14:04:36 +0100
commitcb0b10d7fea3b70322551676b92e42fa0b2692b5 (patch)
treee0a2a12029561cffce3848cf1f2c44f5977c28c9 /dev-libs/grantlee
parentmedia-gfx/maim: EAPI-7 bump (diff)
downloadgentoo-cb0b10d7fea3b70322551676b92e42fa0b2692b5.tar.gz
gentoo-cb0b10d7fea3b70322551676b92e42fa0b2692b5.tar.bz2
gentoo-cb0b10d7fea3b70322551676b92e42fa0b2692b5.zip
dev-libs/grantlee: Fix build with Qt 5.13
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch27
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild5
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch b/dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch
new file mode 100644
index 000000000000..67a92c1f869b
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch
@@ -0,0 +1,27 @@
+From 0cee029ee03ab4906c6d19b57458b5036852b0f8 Mon Sep 17 00:00:00 2001
+From: Michael Pyne <mpyne@kde.org>
+Date: Tue, 18 Dec 2018 17:47:21 -0500
+Subject: [PATCH] Fix build with Qt 5.13 / GCC 8.2.
+
+At this point Grantlee doesn't build for me because QList is an
+incomplete type. I think the compiler is right to complain, so I fix by
+including the appropriate header.
+
+Fixes issue #47.
+---
+ templates/lib/lexer_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/templates/lib/lexer_p.h b/templates/lib/lexer_p.h
+index 275aeea..1ae451a 100644
+--- a/templates/lib/lexer_p.h
++++ b/templates/lib/lexer_p.h
+@@ -24,7 +24,7 @@
+ #include "textprocessingmachine_p.h"
+ #include "token.h"
+
+-template <typename T> class QList;
++#include <QList>
+
+ namespace Grantlee
+ {
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
index 21f665921e53..328ce49c302e 100644
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,7 +29,8 @@ DOCS=( AUTHORS CHANGELOG README.md )
PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
- "${FILESDIR}/${PN}-5.1.0-slot.patch"
+ "${FILESDIR}/${P}-slot.patch"
+ "${FILESDIR}/${P}-qt-5.13.patch"
)
src_prepare() {