summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-01 13:16:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-01 15:07:41 +0200
commite1788803cfa7228a342918b1081bb1e492dcc27c (patch)
tree70c446cdb373229c949bbcde368bfa6dfbd37fd8 /dev-lang
parentapp-emacs/with-editor: Stabilize 3.3.4 ALLARCHES, #937071 (diff)
downloadgentoo-e1788803cfa7228a342918b1081bb1e492dcc27c.tar.gz
gentoo-e1788803cfa7228a342918b1081bb1e492dcc27c.tar.bz2
gentoo-e1788803cfa7228a342918b1081bb1e492dcc27c.zip
dev-lang/haxe: bump to 4.3.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-4.3.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
index 7c44a8158193..23bbfcb6c4a2 100644
--- a/dev-lang/haxe/Manifest
+++ b/dev-lang/haxe/Manifest
@@ -1 +1,2 @@
DIST haxe-4.3.4.tar.gz 8409775 BLAKE2B 929797d71c23724c08c85957be8b39d6802d35990f70a85f8f7c309fa4505dae2b4b24e881ea8f55b02d68af4eb5fb7956c2562cdc5a8f201925a3029bd2cafd SHA512 77f08d5ecd2f0d08d4f44f186120a3f72eb51c712116d50d524f116d981b28fec4e5a03ef0d7c84bf0451caac76a37d642841202d01822cbb5f08981f12998ec
+DIST haxe-4.3.5.tar.gz 8409453 BLAKE2B 5240d9dc215b9636927d2461c6250acc566c7e314850a2804af8a3d4ae8ca6f7ea2c53da5b5852b3714da102c07e58fdfcc36a3104f5fca0612b55cfcfd3e4be SHA512 df8c93542102b359946507ab3b5d33b69556c57a491b0196d2ab51733fcfc03482867550a6f11543aee0c50ce685dfc89220f5d828b982219defcfec3508447c
diff --git a/dev-lang/haxe/haxe-4.3.5.ebuild b/dev-lang/haxe/haxe-4.3.5.ebuild
new file mode 100644
index 000000000000..b922a3ab9e47
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.3.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/
+ https://github.com/HaxeFoundation/haxe/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian is a distribution variant that contains the required git modules.
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/haxe-debian-upstream"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+RESTRICT="strip"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ >=dev-ml/luv-0.5.12:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sha:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/camlp5
+ dev-ml/dune
+ dev-ml/findlib
+"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ export OCAMLOPT="$(usex ocamlopt ocamlopt.opt ocamlopt)"
+}
+
+src_compile() {
+ emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
+ OCAMLOPT="${OCAMLOPT}" INSTALL_DIR="/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR="/usr" install
+ dodoc *.md
+}