summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-05 10:18:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-05 10:28:25 +0200
commit1d580741c3160cc476b7ff599eaff4741f8ff47c (patch)
tree9783fe13ac0dd979c3cfb8805af21c11b9b28b2a /dev-lang
parentdev-lang/python: Remove duplicate xz-utils dep (diff)
downloadgentoo-1d580741c3160cc476b7ff599eaff4741f8ff47c.tar.gz
gentoo-1d580741c3160cc476b7ff599eaff4741f8ff47c.tar.bz2
gentoo-1d580741c3160cc476b7ff599eaff4741f8ff47c.zip
dev-lang/python: Wrap all of pkg_setup into MERGE_TYPE check
Put all of pkg_setup calls into the MERGE_TYPE check. This does not really change anything, as both invoked functions do MERGE_TYPE checks of their own, but it streamlines and optimizes the ebuild a bit. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.13.0_rc3.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-lang/python/python-3.13.0_rc3.ebuild b/dev-lang/python/python-3.13.0_rc3.ebuild
index 6bc1b294d0ed..c97f9faaa41a 100644
--- a/dev-lang/python/python-3.13.0_rc3.ebuild
+++ b/dev-lang/python/python-3.13.0_rc3.ebuild
@@ -132,15 +132,16 @@ pkg_pretend() {
}
pkg_setup() {
- use jit && llvm-r1_pkg_setup
- use test && check-reqs_pkg_setup
- if [[ "${MERGE_TYPE}" != binary ]] && { use test || use pgo; }
- then
- local CONFIG_CHECK
- for f in "${!PYTHON_KERNEL_CHECKS[@]}"; do
- CONFIG_CHECK+="~${f} "
- done
- linux-info_pkg_setup
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ use jit && llvm-r1_pkg_setup
+ use test && check-reqs_pkg_setup
+ if use test || use pgo; then
+ local CONFIG_CHECK
+ for f in "${!PYTHON_KERNEL_CHECKS[@]}"; do
+ CONFIG_CHECK+="~${f} "
+ done
+ linux-info_pkg_setup
+ fi
fi
}