summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-11 03:22:32 +0000
committerSam James <sam@gentoo.org>2022-05-11 03:23:03 +0000
commit07fb1103700af6440f5a9df8cee2eb32847d7c65 (patch)
treeee128d15d85b4b9dbe735c8654c3d3afbbd72e83 /dev-lang
parentninja-utils.eclass: document NINJA_DEPEND (diff)
downloadgentoo-07fb1103700af6440f5a9df8cee2eb32847d7c65.tar.gz
gentoo-07fb1103700af6440f5a9df8cee2eb32847d7c65.tar.bz2
gentoo-07fb1103700af6440f5a9df8cee2eb32847d7c65.zip
dev-lang/python: fix automagic b2 dep; force pkg-config usage
wrt pkg-config: we already depend on it but let's force usage so we know if something goes wrong rather than silently failing. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.11.0_beta1-r2.ebuild (renamed from dev-lang/python/python-3.11.0_beta1-r1.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.11.0_beta1-r1.ebuild b/dev-lang/python/python-3.11.0_beta1-r2.ebuild
index 1afeef7be7a4..df656602e75c 100644
--- a/dev-lang/python/python-3.11.0_beta1-r1.ebuild
+++ b/dev-lang/python/python-3.11.0_beta1-r2.ebuild
@@ -40,6 +40,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
app-arch/bzip2:=
app-arch/xz-utils:=
+ app-crypt/libb2
>=dev-libs/expat-2.1:=
dev-libs/libffi:=
sys-apps/util-linux:=
@@ -195,6 +196,7 @@ src_configure() {
--with-system-expat
--with-system-ffi
--with-platlibdir=lib
+ --with-pkg-config=yes
$(use_with lto)
$(use_enable pgo optimizations)