summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-26 18:18:57 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-26 18:28:15 +0200
commit248cfb7b7c88c8ad3b92490418655c22466bfddf (patch)
tree7d9afb32121a25616b24a12fb6884a25fb1917ed /dev-dotnet/csharp-gentoodotnetinfo
parentapp-eselect/eselect-dotnet: drop old 0.1.0 (diff)
downloadgentoo-248cfb7b7c88c8ad3b92490418655c22466bfddf.tar.gz
gentoo-248cfb7b7c88c8ad3b92490418655c22466bfddf.tar.bz2
gentoo-248cfb7b7c88c8ad3b92490418655c22466bfddf.zip
dev-dotnet/csharp-gentoodotnetinfo: bump to 1.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/csharp-gentoodotnetinfo')
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/Manifest2
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/Manifest b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
index 98e4edb90b42..c1efc135dead 100644
--- a/dev-dotnet/csharp-gentoodotnetinfo/Manifest
+++ b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
@@ -1 +1,3 @@
DIST csharp-gentoodotnetinfo-0.1.0.tar.bz2 8207 BLAKE2B d6c9bbd83b15487c669bb933c51a266788e7217a59fccb6e6fb87b66cd77ea67325859fb030d45a9ae00a542c23158a88d90ab915956d2086a4c2a3954d6a75f SHA512 78cbb0768eb8434c5ccf7c3ddbee8fc3c742e3875a05d99a72fbaa798fdd92a0bd231be873be01385b1933f51c14af9a2827e6da9495fc943898984684ab077c
+DIST csharp-gentoodotnetinfo-1.0.0.tar.bz2 11273 BLAKE2B dc813e3af220b8a348716e3fd95640cd284083a463b007e5943b0f335161d3491637e47f894f276dd45b8dae74b2d057874425beef1bf3463b50eee9e480b495 SHA512 3900dd435cc122e2c368c4040413f64f5f232cb374d672f843b73c41a9a1aef2903db53f5688c223f478a521908001c025d74fbf1d59bb7608be26cf780eaf38
+DIST system.commandline.2.0.0-beta4.22272.1.nupkg 616636 BLAKE2B 5252560598c4cd67348520cea086c37b4151b984a61238de1984838975340247b16050113422b1765931bdfc1dee38e226789b6427e56ab7c3a36bf07d0bcc20 SHA512 979a7e66ba29e17bc5bec42e926ed15362e23ae403e498c955e09dffc4d3baa14777a06f95e25d591fc9757a0eaa18deb9e4662a1ca1663fa300f509a4a0383c
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
new file mode 100644
index 000000000000..31877c28a815
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=7.0
+NUGETS="
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION=".NET information tool for Gentoo"
+HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm ~arm64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=(
+ Source/v1/gentoo-dotnet-info-app/GentooDotnetInfo/GentooDotnetInfo.csproj
+)
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ local launcher_dll="/usr/share/${P}/GentooDotnetInfo.dll"
+
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher_portable "${launcher_dll}" gentoo-dotnet-info
+
+ einstalldocs
+}