summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-26 19:22:54 +0000
committerSam James <sam@gentoo.org>2022-02-26 19:53:26 +0000
commitaeea2bbcab092bc8f37826e65f40d776a476ea85 (patch)
treeaad81cf402e09c7e3c79730d18bbad281dd3a493 /app-text/wv2
parentvirtual/podofo-build: Bump to version 0.9.7 (diff)
downloadgentoo-aeea2bbcab092bc8f37826e65f40d776a476ea85.tar.gz
gentoo-aeea2bbcab092bc8f37826e65f40d776a476ea85.tar.bz2
gentoo-aeea2bbcab092bc8f37826e65f40d776a476ea85.zip
app-text/wv2: update EAPI 6 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/wv2')
-rw-r--r--app-text/wv2/wv2-0.4.2-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/wv2/wv2-0.4.2-r3.ebuild b/app-text/wv2/wv2-0.4.2-r3.ebuild
new file mode 100644
index 000000000000..d983f3763221
--- /dev/null
+++ b/app-text/wv2/wv2-0.4.2-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
+HOMEPAGE="http://wvware.sourceforge.net"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="zlib"
+
+RDEPEND="dev-libs/glib
+ >=gnome-extra/libgsf-1.8:=
+ virtual/libiconv
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
+)
+
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
+
+src_configure() {
+ # Due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ cmake_src_configure
+}