summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-03 22:10:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-03 22:10:14 +0300
commit783fdd7e3f6d7eec3493cdc941c9c41095f6de0e (patch)
tree6aa55006d3133416172e95c7c7c659c7be065e7e /app-shells
parentapp-arch/7zip: add 24.07 (diff)
downloadgentoo-783fdd7e3f6d7eec3493cdc941c9c41095f6de0e.tar.gz
gentoo-783fdd7e3f6d7eec3493cdc941c9c41095f6de0e.tar.bz2
gentoo-783fdd7e3f6d7eec3493cdc941c9c41095f6de0e.zip
app-shells/liquidprompt: add 2.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/liquidprompt/Manifest1
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.2.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
index 141d3966408d..c9cf1fa9d341 100644
--- a/app-shells/liquidprompt/Manifest
+++ b/app-shells/liquidprompt/Manifest
@@ -1,3 +1,4 @@
DIST bash-preexec.sh 12667 BLAKE2B 1a19e3d7c2b74ae7572375b7af11c20a3506464c1ae31b90439529422ae74fcdb26f71bfa3d9128180852b511335cd79a9ab3d951aa9d4d1749c122cd3444013 SHA512 c77093d7049ad97406519e3f7bd98dbfa6ca3670c635995484aa5635a47e0243c885868dc48bb89d9f15d2c8082657eefb895e1fb764c3b9e0498cfee7797120
DIST liquidprompt-2.1.2.tar.gz 621356 BLAKE2B b5c3c52179f86fc42164e08a01f4e114f5e7ce1cdb5fb19ef1c02e85569e895cb5f1cc2f61bf6f66380d5c20bc6daf41547eb281990221528d5c1d85b61d1329 SHA512 685da50d347ba0d7c6881d87426344840cc7ab960067035b43f9658c51d7d5cf89e80f4bf8344b49f3858fe91bcfd57dcfaf9a253246fc1a7ebedbba474dc5ff
DIST liquidprompt-2.2.0.tar.gz 986151 BLAKE2B aad40582ddb3e4f611e4632ebff0a6625d169a18d35013d204b1912196c770f04361a617c54e3c798b9828fba3919c0af328f81e1994ba3c987321b551ed9634 SHA512 1ccefcdb7b58697ac9b27e3e94ef1527c17ac36e9e405930f5b8b2a906cad5789ed9f77271dbcc66b3ef3457b307df370cfc60f88dc13e9d82ba3de7e2708421
+DIST liquidprompt-2.2.1.tar.gz 988223 BLAKE2B f0c177b6c7a4e7a1d11fbed692d91e6c2765f364809948364e07cbef0dc0ca4247912b9a000a3b8c646aa56869d605bbb72b4483a2beec30b31c302100dbb922 SHA512 cc169f4dc5e8f082163de9e4e1d58d0a775fc6e7efcd40bdeb7986a0b0ca7710b1f34cec03e78db00fc9f032f2243eee3bbc18c3b38132332fb7101f62e4d3aa
diff --git a/app-shells/liquidprompt/liquidprompt-2.2.1.ebuild b/app-shells/liquidprompt/liquidprompt-2.2.1.ebuild
new file mode 100644
index 000000000000..8aae627d6efa
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt https://liquidprompt.readthedocs.io/"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://raw.githubusercontent.com/rcaloras/bash-preexec/0.4.1/bash-preexec.sh
+ )
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "${DISTDIR}/bash-preexec.sh" tests/ || die
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh bash || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins -r themes templates tools
+
+ insinto /etc/
+ ./tools/config-from-doc.sh > "${T}/liquidpromptrc" || die
+ newins "${T}/liquidpromptrc" liquidpromptrc
+}