summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-07-07 00:16:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-09 08:40:40 +0200
commitd82d4e7bb2cdf16210dbd3fdcf0efb8c3d8a9f75 (patch)
tree42ad7f342237f6cfdbe18d17867e8f06d9c5e3ed /app-office
parentnet-irc/epic5: drop 2.0.1-r1 (diff)
downloadgentoo-d82d4e7bb2cdf16210dbd3fdcf0efb8c3d8a9f75.tar.gz
gentoo-d82d4e7bb2cdf16210dbd3fdcf0efb8c3d8a9f75.tar.bz2
gentoo-d82d4e7bb2cdf16210dbd3fdcf0efb8c3d8a9f75.zip
app-office/impressive: version bump 0.13.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://bugs.gentoo.org/845537 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26249 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/impressive/Manifest1
-rw-r--r--app-office/impressive/impressive-0.13.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index fafc98ce8a7e..a35e25b95d61 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1 +1,2 @@
DIST Impressive-0.13.0-beta2.tar.gz 311905 BLAKE2B fb912ada1f44b2af9bd1eed4c7e1d4bfae5ba42449a9b1a154500a9d892c1070c9da127c8c3cbd35ce033a768a00db359deb1a045996cfeb7253f92d289aed82 SHA512 45c094d30e898a1843869cdcd490315c8280bbe2f5cc58f7695be2f0876075718517a502af16e040981b3f3a8fd955000d9ff76e20850b4bedf52c0d2bbd098e
+DIST Impressive-0.13.1.tar.gz 215989 BLAKE2B 6591e5fa2c34e7e6f2283b9b6f8cce7485fc8932eea571af96c895bbe23202af195eec0318272667d5656f3aed7a88a21a20397224c7c0cc7c9252364d832371 SHA512 f6221337f9dd79f552fb083e1ea7484aeadec1f8d8e05b4e1b7f6a94037b5026022819b346968dea67dbdb1b646d0571a7aeef26f15c25bee88c5b9c2791cf2b
diff --git a/app-office/impressive/impressive-0.13.1.ebuild b/app-office/impressive/impressive-0.13.1.ebuild
new file mode 100644
index 000000000000..298f8cb868f6
--- /dev/null
+++ b/app-office/impressive/impressive-0.13.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit optfeature python-r1
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
+
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
+
+S="${WORKDIR}/${PN^}-${PV/_/-}"
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}