summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2024-06-02 22:32:46 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2024-06-02 22:32:46 +0200
commitc475f96a121020fef4718b4b1af0aab9872c4dc7 (patch)
treeb8a7d493bc2c10ea14f08d854b6cf85455e82096 /app-laptop
parentapp-laptop/tuxedo-drivers: add 4.5.0 (diff)
downloadgentoo-c475f96a121020fef4718b4b1af0aab9872c4dc7.tar.gz
gentoo-c475f96a121020fef4718b4b1af0aab9872c4dc7.tar.bz2
gentoo-c475f96a121020fef4718b4b1af0aab9872c4dc7.zip
app-laptop/tuxedo-control-center-bin: add 2.1.8
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-control-center-bin/Manifest1
-rw-r--r--app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-2.1.8.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-control-center-bin/Manifest b/app-laptop/tuxedo-control-center-bin/Manifest
index d290fc450c30..5cc52157f5f5 100644
--- a/app-laptop/tuxedo-control-center-bin/Manifest
+++ b/app-laptop/tuxedo-control-center-bin/Manifest
@@ -1,2 +1,3 @@
DIST tuxedo-control-center_2.0.2.rpm 80479580 BLAKE2B 7c83fd64ee8d7ca8b50e3634d36567d3a930656c5e34f23fd7b703bc560d35376701df081aaa5d09692df61689a5a81ec87a8a4a8d55db2cc2577c638d02731b SHA512 e9c9abfc2c0d0e226038f49d388a31625120f6780558b7606e719be61a4563c698e4c46d6f0d6a3e774179a5f5785dc07ff243901578da474dfa80cf71fe0394
DIST tuxedo-control-center_2.0.8.rpm 80495472 BLAKE2B 30ff8c5073b42299b4def5958254393727957b4289958bf486520fc6bad83184f3f8fc5baf97d2040ecfa551cafe8b2225b15cbbc8a6012113a9a64471a13aa6 SHA512 6f24394d1eda91e5a58fae29926f42271350917c9222062d99967f42f465e8769e6c50510967923612eb54d5c2921512adc4e6a5c743b922197e2603d6bc5c9b
+DIST tuxedo-control-center_2.1.8.rpm 81160628 BLAKE2B aa50c9b2fd6e6a0b0a996fcb0243c57fe5cd3d82e5e0d372c46a409a3bef51c52e45c0ccab30cb430907cdb8dce28019297d5bb6f359a9bfeafd804d4ae48295 SHA512 0caf10c24b54e943dd465a9f87b74916da5f2424ddf57a2a50d6a3f38b19d83d0b2512982b36db2cb8d07b632fc16b999904a2b447f80507b6af33a40a01c22e
diff --git a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-2.1.8.ebuild b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-2.1.8.ebuild
new file mode 100644
index 000000000000..374b1c614f5a
--- /dev/null
+++ b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-2.1.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm systemd xdg-utils
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Tool to control performance, energy, fan and comfort settings on TUXEDO laptops"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-control-center"
+SRC_URI="https://rpm.tuxedocomputers.com/opensuse/15.4/x86_64/${MY_PN}_${PV}.rpm"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="strip splitdebug"
+
+DEPEND=">=app-laptop/tuxedo-drivers-3.2.14"
+RDEPEND="
+ ${DEPEND}
+ app-accessibility/at-spi2-core
+ dev-libs/nss
+ dev-libs/nspr
+ media-libs/alsa-lib
+ media-libs/mesa[X(+)]
+ net-print/cups
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+# See bug #827729
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+QA_PREBUILT="opt/tuxedo-control-center/*"
+
+src_prepare() {
+ default
+ rm -rf usr/lib || die "could not remove usr/lib"
+ mkdir files || die "could not create files dir"
+}
+
+src_install() {
+ insinto /
+ doins -r usr opt
+ find . -type f -perm -a=x | while read f; do
+ fperms 0755 "${f/./}"
+ done
+
+ dosym ../../opt/tuxedo-control-center/tuxedo-control-center /usr/bin/tuxedo-control-center
+
+ insinto /usr/share/dbus-1/system.d/
+ doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/com.tuxedocomputers.tccd.conf
+
+ insinto /usr/share/polkit-1/actions
+ doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/com.tuxedocomputers.tccd.policy
+
+ systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd.service
+ systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd-sleep.service
+
+ newinitd "${FILESDIR}/tccd.initd" tccd
+}
+
+pkg_config() {
+ ebegin "Reloading systemd"
+ systemctl daemon-reload
+ eend $?
+ ebegin "Enabling and starting tccd.service"
+ systemctl enable --now tccd
+ eend $?
+ ebegin "Enabling and starting tccd-sleep.service"
+ systemctl enable --now tccd-sleep
+ eend $?
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ elog
+ elog "You need to enable tccd and tccd-sleep service before running tuxedo-control-center"
+ elog
+ elog "For your convenience, if you use systemd, you may just call:"
+ elog " emerge --config =app-laptop/${PF}"
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}