summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:14:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:15:03 +0300
commit9113fa2f64b085739068cda76ed82dbcadd9b263 (patch)
treef3aaf0f92230b45bb3f73e6f806e827250a44cfb /app-editors
parentdev-ml/ordering: drop 3.13.1 (diff)
downloadgentoo-9113fa2f64b085739068cda76ed82dbcadd9b263.tar.gz
gentoo-9113fa2f64b085739068cda76ed82dbcadd9b263.tar.bz2
gentoo-9113fa2f64b085739068cda76ed82dbcadd9b263.zip
app-editors/vscode: add 1.92.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.92.0.ebuild131
2 files changed, 134 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index fd9d43673399..2624a141405f 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -4,3 +4,6 @@ DIST vscode-1.91.0-arm64.tar.gz 138968980 BLAKE2B 591a068e0de00a5898c9f2c83aaae7
DIST vscode-1.91.1-amd64.tar.gz 142223657 BLAKE2B 31fba4dc0940f217648554705debf13e0caf71e84a29f85c98e861b6c78327850724262ba1b927c10a8692b4a6db6fd8ddaec69dfa577f74ca6ef696f87dc3a7 SHA512 01ff19cd5a79550ab568ef6d9ad8dc6a0e6e15560dd01d97c30f6e6d5930430cccd0675c80791df06ffbd83351f85901f1b0c684b158b6eb1f68d21dccee7508
DIST vscode-1.91.1-arm.tar.gz 127169905 BLAKE2B 5ac2da6c115851d796bfc7835d689a59476e4bf8db770c5089b2c484776ee270067f47574899ee57c49fd6bf5ef3ea27ad8a0bf183ff4d5aa0a78aa69a252276 SHA512 e136e79d0d70b386bcf8b81b7aa3293d5697f681fe85b4d8e183877b62a131a9cfe9a5f4e0cbf34d06d57d0e9e6513787a8061995ec7c2984df62e9d96b8195a
DIST vscode-1.91.1-arm64.tar.gz 138976160 BLAKE2B 573ab5e6fa349ac80044b6d5f3ab4d9d7947248181dd20584b1ade1eb1b42fbcbab0f8a232bcb7898dbe4e9dd2eca4cc4e3d00dfe8f0927b2807d4c94a299d1b SHA512 18abbeea0c78c8f1b8dfa4fb88782f426b8e00f3352af91679ccd345bf385f7b142f5a84acf6cf41c982dca2190e0b73284b3c8b4d26c97e571247b7e12fc412
+DIST vscode-1.92.0-amd64.tar.gz 144719694 BLAKE2B 32598d9c45dd8ae921511587f44376237d57ce15e2b417595bc7828416a1e4f0a35b7bc7b90cd60e7b98c99f9f6ec1eb5be1923aa3ef9c336768e7b9ca53717f SHA512 8e204f31784b27437a612ceb0ba05b03049e4b735ffd3808f6b3ce979ce9b3a5804fb1726afac40dcf06c215ccbe9be5de693fd789dbe75b788ea3104b0ee5e3
+DIST vscode-1.92.0-arm.tar.gz 129685400 BLAKE2B 22d95a781e409b4beb97a3463605372651304174e687b50ca9cf98c7daa64935e0cfb3eef48ed0d70cd85194806798dfeb8bb5838e388ecfcc3277aaa09acaaf SHA512 7411d67b3bd338ea855fba02ff2f87506ab9dffe2da3871d45a9511ac08e3947d3864e786502b6875fc48033860cfecfab8a4c22440cacca97ef338e96ffa9da
+DIST vscode-1.92.0-arm64.tar.gz 141628799 BLAKE2B 94ffd063dfcd9352664b17a65a8b64474d1a7a0df6cfd98efa9f6f1bf9f31b1e8f807313c9e154c96e539db3a29bd3073668a70f98a280810b42d7c61957dfde SHA512 6aa04f37c15b74db961dff439dbdb14e54ca00b28f0358e39fd85772ff6390c71c8828b21b137707b0a9a99a7b33fe140cbe900e80d7df6b19abd970ddc9c436
diff --git a/app-editors/vscode/vscode-1.92.0.ebuild b/app-editors/vscode/vscode-1.92.0.ebuild
new file mode 100644
index 000000000000..c06246461b83
--- /dev/null
+++ b/app-editors/vscode/vscode-1.92.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}