summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-16 12:28:50 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-16 12:28:50 -0400
commit080155ab1dcb60de7df0ef898689a0840ad304da (patch)
tree4a52ce2b5e809e6b9cb1be94a2dea18e3b7b1fe8
parentmetadata: Update hashes (diff)
downloadx11-080155ab1dcb60de7df0ef898689a0840ad304da.tar.gz
x11-080155ab1dcb60de7df0ef898689a0840ad304da.tar.bz2
x11-080155ab1dcb60de7df0ef898689a0840ad304da.zip
app-benchmarks/glmark2: Add patch to fix build with gcc-12
Closes: https://github.com/gentoo/x11/issues/4 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-benchmarks/glmark2/files/2021.12-libmatrix-Add-missing-utility-include.patch27
-rw-r--r--app-benchmarks/glmark2/glmark2-2021.12.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/app-benchmarks/glmark2/files/2021.12-libmatrix-Add-missing-utility-include.patch b/app-benchmarks/glmark2/files/2021.12-libmatrix-Add-missing-utility-include.patch
new file mode 100644
index 00000000..6d99d87c
--- /dev/null
+++ b/app-benchmarks/glmark2/files/2021.12-libmatrix-Add-missing-utility-include.patch
@@ -0,0 +1,27 @@
+From d1ca3f53c96dc8a4048b17dc16147a8fac782d4a Mon Sep 17 00:00:00 2001
+From: Alexandros Frantzis <alexandros.frantzis@collabora.com>
+Date: Mon, 14 Feb 2022 13:54:09 +0200
+Subject: [PATCH] libmatrix: Add missing <utility> include
+
+Fixes compilation with GCC 12.
+
+Fixes #169
+---
+ src/libmatrix/program.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/libmatrix/program.h b/src/libmatrix/program.h
+index f95b470..1c9de08 100644
+--- a/src/libmatrix/program.h
++++ b/src/libmatrix/program.h
+@@ -15,6 +15,7 @@
+ #include <string>
+ #include <vector>
+ #include <map>
++#include <utility>
+ #include "mat.h"
+
+ // Simple shader container. Abstracts all of the OpenGL bits, but leaves
+--
+2.35.1
+
diff --git a/app-benchmarks/glmark2/glmark2-2021.12.ebuild b/app-benchmarks/glmark2/glmark2-2021.12.ebuild
index 00290d61..28e00b55 100644
--- a/app-benchmarks/glmark2/glmark2-2021.12.ebuild
+++ b/app-benchmarks/glmark2/glmark2-2021.12.ebuild
@@ -39,6 +39,10 @@ BDEPEND="
REQUIRED_USE="|| ( opengl gles2 )
|| ( drm wayland X )"
+PATCHES=(
+ "${FILESDIR}"/${PV}-libmatrix-Add-missing-utility-include.patch
+)
+
src_configure() {
local flavors=()