summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/phpwirelessmap/phpwirelessmap-0.4.1.ebuild')
-rw-r--r--www-apps/phpwirelessmap/phpwirelessmap-0.4.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/www-apps/phpwirelessmap/phpwirelessmap-0.4.1.ebuild b/www-apps/phpwirelessmap/phpwirelessmap-0.4.1.ebuild
deleted file mode 100644
index c73c98e..0000000
--- a/www-apps/phpwirelessmap/phpwirelessmap-0.4.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit webapp depend.php
-
-DESCRIPTION="phpWirelessMap is a free dynamic map system for wireless communities."
-HOMEPAGE="http://sourceforge.net/projects/phpwirelessmap"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND="virtual/httpd-cgi
- <virtual/mysql-5.1"
-
-need_php4_httpd
-
-pkg_setup() {
- if ! PHPCHECKNODIE="yes" require_php_with_use mysql || \
- ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
- die "Re-install ${PHP_PKG} with mysql and either gd or gd-external in USE."
- fi
- webapp_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- mv config-sample.inc.php config.inc.php
-
- # Remove .cvs* files and CVS directories
- find "${S}" -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
-}
-
-src_install() {
- webapp_src_preinst
-
- local docs="{BUGS,FAQ,INSTALL,TODO}.txt doc/{README,MySQL.schema}"
-
- dodoc ${docs}
- for doc in ${docs} INSTALL LICENSE.txt docs/MYSQL.03to04.schema ; do
- rm -f ${doc}
- done
- dohtml -r docs/
- rm -rf docs/
-
- cp -r . "${D}"${MY_HTDOCSDIR}
-
- webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
- fperms 0640 ${MY_HTDOCSDIR}/config.inc.php
- webapp_serverowned ${MY_HTDOCSDIR}/config.inc.php
-
- webapp_src_install
-}
-
-pkg_postinst() {
- elog "Remember to edit config-sample.inc.php to match your configuration options"
- elog "You may also want to create your MySQL database"
- elog "Use the doc/MySQL.schema script to do that"
- elog
- webapp_pkg_postinst
-}