summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2011-06-08 12:50:52 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2011-06-08 12:50:52 +0200
commita36dc6bb320ab9f08b5db8d6b24740f36d18ab51 (patch)
treee5188a080b301f8a3a103c7ceb57bad980d01c57 /Makefile
parentPrepare KV test for kernel version 3.0 (diff)
downloadudev-gentoo-scripts-a36dc6bb320ab9f08b5db8d6b24740f36d18ab51.tar.gz
udev-gentoo-scripts-a36dc6bb320ab9f08b5db8d6b24740f36d18ab51.tar.bz2
udev-gentoo-scripts-a36dc6bb320ab9f08b5db8d6b24740f36d18ab51.zip
make dist: Add check for uncommited changes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5c69b7c..802c764 100644
--- a/Makefile
+++ b/Makefile
@@ -43,11 +43,15 @@ install:
@install -m 0644 rc/confd/udev.confd $(DESTDIR)$(CONFD)/udev
@install -m 0755 rc/baselayout1/* $(DESTDIR)$(RCADDON)
+check-git-repository:
+ git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }
+ git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
+
test:
@echo "Running tests"
@./test-kv.sh
-dist: test
+dist: check-git-repository test
git archive --format=tar --prefix=$(DESTNAME)/ HEAD | bzip2 > $(DESTNAME).tar.bz2
.PHONY: install test