summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 14:05:15 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 14:05:15 +0000
commit380b19423bf5e579861f181b1b6557060a18c9aa (patch)
tree5f18727f4e77798763b5cd9a78be4bffe0ec33a8 /media-sound/basicdsp/basicdsp-1.01.ebuild
parentmedia-gfx/ngplant: Use wxwidgets.eclass (diff)
downloadsunrise-380b19423bf5e579861f181b1b6557060a18c9aa.tar.gz
sunrise-380b19423bf5e579861f181b1b6557060a18c9aa.tar.bz2
sunrise-380b19423bf5e579861f181b1b6557060a18c9aa.zip
media-sound/basicdsp: Use wxwidgets.eclass, respect CXX
svn path=/sunrise/; revision=11937
Diffstat (limited to 'media-sound/basicdsp/basicdsp-1.01.ebuild')
-rw-r--r--media-sound/basicdsp/basicdsp-1.01.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/media-sound/basicdsp/basicdsp-1.01.ebuild b/media-sound/basicdsp/basicdsp-1.01.ebuild
index 3897bffcb..5a15255f6 100644
--- a/media-sound/basicdsp/basicdsp-1.01.ebuild
+++ b/media-sound/basicdsp/basicdsp-1.01.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+EAPI="3"
+
+WX_GTK_VER="2.8"
+
+inherit eutils toolchain-funcs wxwidgets
DESCRIPTION="A program for experimenting with simple audio DSP algorithms"
HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/"
@@ -14,14 +18,12 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
-DEPEND=">=x11-libs/wxGTK-2.6.3"
+DEPEND="x11-libs/wxGTK:2.8[X]"
RDEPEND=${DEPEND}
-src_unpack() {
- unpack $A
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/makefile.patch
+ tc-export CXX
}
src_install() {