summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Barrios Romero (eldruin) <eldruin@gmail.com>2010-02-17 20:05:41 +0000
committerDiego Barrios Romero (eldruin) <eldruin@gmail.com>2010-02-17 20:05:41 +0000
commitb1f0d950d0801e7684bd68971f297b8ef3798008 (patch)
tree1e7d4462bedcd6a078161fd196a43bc1abf9e34f /dev-cpp/ETL/ETL-9999.ebuild
parentsunrise/ profiles/package.mask: mandvd removal. Replaced by 2mandvd (diff)
downloadsunrise-b1f0d950d0801e7684bd68971f297b8ef3798008.tar.gz
sunrise-b1f0d950d0801e7684bd68971f297b8ef3798008.tar.bz2
sunrise-b1f0d950d0801e7684bd68971f297b8ef3798008.zip
dev-cpp/ETL: New live ebuild for ETL thanks to the irc people
svn path=/sunrise/; revision=10158
Diffstat (limited to 'dev-cpp/ETL/ETL-9999.ebuild')
-rw-r--r--dev-cpp/ETL/ETL-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/ETL/ETL-9999.ebuild b/dev-cpp/ETL/ETL-9999.ebuild
new file mode 100644
index 000000000..a2bf64c95
--- /dev/null
+++ b/dev-cpp/ETL/ETL-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit autotools git
+
+DESCRIPTION="Multiplatform class and template library designed to complement and supplement the C++ STL"
+
+HOMEPAGE="http://www.synfig.org/"
+EGIT_REPO_URI="git://synfig.git.sourceforge.net/gitroot/synfig/synfig"
+EGIT_FETCH_CMD="git clone --depth 1"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ S="${WORKDIR}/${P}/ETL"
+ cd "${S}"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS README NEWS || die
+}