summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-04-08 15:20:22 +0000
committerMichał Górny <mgorny@gentoo.org>2010-04-08 15:20:22 +0000
commit832dd69456906a0f7456232094571d9df61582fc (patch)
treee8ccb6c4de37e476a1952f2776294841d7249c25
parentin portage (diff)
downloadsunrise-832dd69456906a0f7456232094571d9df61582fc.tar.gz
sunrise-832dd69456906a0f7456232094571d9df61582fc.tar.bz2
sunrise-832dd69456906a0f7456232094571d9df61582fc.zip
dev-python/Whoosh: Add support for Python ABIs and adjust the Python depend.
svn path=/sunrise/; revision=10415
-rw-r--r--dev-python/Whoosh/ChangeLog4
-rw-r--r--dev-python/Whoosh/Manifest4
-rw-r--r--dev-python/Whoosh/Whoosh-0.3.18.ebuild4
3 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/Whoosh/ChangeLog b/dev-python/Whoosh/ChangeLog
index 058d485e8..cf7bb35eb 100644
--- a/dev-python/Whoosh/ChangeLog
+++ b/dev-python/Whoosh/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Apr 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ Whoosh-0.3.18.ebuild:
+ Add support for Python ABIs and adjust the Python depend.
+
07 Apr 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
-Whoosh-0.3.15.ebuild, +Whoosh-0.3.18.ebuild:
Version bump.
diff --git a/dev-python/Whoosh/Manifest b/dev-python/Whoosh/Manifest
index 08997b73d..7f649b4a1 100644
--- a/dev-python/Whoosh/Manifest
+++ b/dev-python/Whoosh/Manifest
@@ -1,4 +1,4 @@
DIST Whoosh-0.3.18.tar.gz 253960 RMD160 77aab2a388070ec3c15906ff7c5f3a7e55fe688f SHA1 d04f26060443e7066338743eaa523f20d80b4ee3 SHA256 29bfbaf8ad97308c6843a70671ec0d291a92349b3e5ccc99fc87024f7bb82db0
-EBUILD Whoosh-0.3.18.ebuild 414 RMD160 29b7b423ebbf820e32bca3208fb8bf8df77a05e4 SHA1 f2008354dbd42a6dea02a39f4a8dac705b7129b1 SHA256 6b064fdb1771498d2e2b22031444f7c4b4abba0e5e515b597555a37174fd41fb
-MISC ChangeLog 1645 RMD160 03c183a6d8b7867090522072e8c4003bacd3b7f3 SHA1 3ee8e5e0a89d63f74fb6b00b3a2124dd2a27ea01 SHA256 b299602015ec93a704334bf8744d1edd07d153b4fd5bef601f5b9e836d75cd6d
+EBUILD Whoosh-0.3.18.ebuild 480 RMD160 6edbb30caec51c7408cead58c594fdff265469e6 SHA1 a36e622796911db4388910764870004ee6d838ce SHA256 7d0f48abe0d624301afbbd52bf415b74ed5e4bd9d9b464231ebed23f1d2d5a7f
+MISC ChangeLog 1794 RMD160 71c4cf13cacbface12875ddcfabd0b333812d02a SHA1 4becc50548648b359ca5ce3a45d8eff2c4aee540 SHA256 db56bd3f53584ac09204dece8bbcd140865e220d3a89ff68de5905fd5a37b797
MISC metadata.xml 171 RMD160 ed284df01c230fc7990a6b5888b39166d23f29ba SHA1 f3d64a69044b710e23fb874b3ee4cd338858c8b4 SHA256 a7b30fbacd0e4c312c07a3efac112a3794c81d134442d8104325734d03425adf
diff --git a/dev-python/Whoosh/Whoosh-0.3.18.ebuild b/dev-python/Whoosh/Whoosh-0.3.18.ebuild
index 8bbc84006..3e7b0cb84 100644
--- a/dev-python/Whoosh/Whoosh-0.3.18.ebuild
+++ b/dev-python/Whoosh/Whoosh-0.3.18.ebuild
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"