aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch')
-rw-r--r--sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch b/sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch
new file mode 100644
index 000000000..42d7c5663
--- /dev/null
+++ b/sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch
@@ -0,0 +1,40 @@
+diff --git a/Code/GraphMol/MolInterchange/CMakeLists.txt b/Code/GraphMol/MolInterchange/CMakeLists.txt
+index 0c1e9a0de..e6f4fe753 100644
+--- a/Code/GraphMol/MolInterchange/CMakeLists.txt
++++ b/Code/GraphMol/MolInterchange/CMakeLists.txt
+@@ -1,24 +1,5 @@
+
+-if(NOT EXISTS "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0")
+- downloadAndCheckMD5("https://github.com/Tencent/rapidjson/archive/v1.1.0.tar.gz"
+- "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz"
+- "badd12c511e081fec6c89c43a7027bce")
+- execute_process(COMMAND ${CMAKE_COMMAND} -E tar zxf
+- ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/External)
+- # comment out a line which causes a compilation error on some platforms
+- # (based on the change which has already been applied to the RapidJSON master branch, see
+- # https://github.com/Tencent/rapidjson/blob/ab1842a2dae061284c0a62dca1cc6d5e7e37e346/include/rapidjson/document.h#L414)
+- file(READ ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h RAPIDJSON_DOCUMENT_H)
+- string(REGEX REPLACE
+- "( *)(GenericStringRef& operator=\\(const GenericStringRef& rhs\\) { s = rhs\\.s. length = rhs\\.length. })" "\\1//\\2"
+- RAPIDJSON_DOCUMENT_H "${RAPIDJSON_DOCUMENT_H}")
+- file(WRITE ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h "${RAPIDJSON_DOCUMENT_H}")
+-else()
+- message("-- Found RapidJSON source in ${CMAKE_SOURCE_DIR}/External")
+-endif()
+-
+-include_directories(${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include)
++include_directories(/usr/include/rapidjson)
+
+
+ rdkit_library(MolInterchange
+diff --git a/Code/MinimalLib/CMakeLists.txt b/Code/MinimalLib/CMakeLists.txt
+index 84808a971..987b155f8 100644
+--- a/Code/MinimalLib/CMakeLists.txt
++++ b/Code/MinimalLib/CMakeLists.txt
+@@ -1,5 +1,4 @@
+ include_directories(${RDKit_ExternalDir})
+-include_directories(${RDKit_ExternalDir}/rapidjson-1.1.0/include)
+
+ if(RDK_BUILD_MINIMAL_LIB)
+ set(MINIMAL_LIB_LIBRARIES "MolInterchange_static;Abbreviations_static;"