aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-22 10:50:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-22 10:50:26 +0200
commit42840069a800346e540ed29895c7b8b43b6fce56 (patch)
tree58ddcc1bf67bfccb123514740c3de392f5310368 /sys-devel
parentsci-biology/imagej: add 1.54f, drop 1.54d (diff)
downloadsci-42840069a800346e540ed29895c7b8b43b6fce56.tar.gz
sci-42840069a800346e540ed29895c7b8b43b6fce56.tar.bz2
sci-42840069a800346e540ed29895c7b8b43b6fce56.zip
sys-devel/DPC++: add patch for gcc13
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/DPC++/DPC++-2022.12.ebuild1
-rw-r--r--sys-devel/DPC++/files/DPC++-2022.12-gcc13.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/sys-devel/DPC++/DPC++-2022.12.ebuild b/sys-devel/DPC++/DPC++-2022.12.ebuild
index 59e169180..25ac88770 100644
--- a/sys-devel/DPC++/DPC++-2022.12.ebuild
+++ b/sys-devel/DPC++/DPC++-2022.12.ebuild
@@ -73,6 +73,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-system-libs.patch"
+ "${FILESDIR}/${P}-gcc13.patch"
)
src_configure() {
diff --git a/sys-devel/DPC++/files/DPC++-2022.12-gcc13.patch b/sys-devel/DPC++/files/DPC++-2022.12-gcc13.patch
new file mode 100644
index 000000000..047170cd3
--- /dev/null
+++ b/sys-devel/DPC++/files/DPC++-2022.12-gcc13.patch
@@ -0,0 +1,12 @@
+diff --git a/sycl/include/sycl/sycl_span.hpp b/sycl/include/sycl/sycl_span.hpp
+index 33b942fbc..395694573 100644
+--- a/sycl/include/sycl/sycl_span.hpp
++++ b/sycl/include/sycl/sycl_span.hpp
+@@ -128,6 +128,7 @@ template<class Container>
+ #include <cassert> // for assert
+ #include <cstddef> // for byte
+ #include <iterator> // for iterators
++#include <cstdint>
+ #include <type_traits> // for remove_cv, etc
+
+ #define _SYCL_SPAN_TEMPLATE_VIS