aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 13:28:53 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:21 +0200
commit6db4f7ea609d96a35c61ee7fb0b1bc2fcfb3b73f (patch)
tree283692b7591610832391c2c40b8f068e79e273c6 /sci-physics
parentdev-python/awkward: add 2.6.9 (diff)
downloadsci-6db4f7ea609d96a35c61ee7fb0b1bc2fcfb3b73f.tar.gz
sci-6db4f7ea609d96a35c61ee7fb0b1bc2fcfb3b73f.tar.bz2
sci-6db4f7ea609d96a35c61ee7fb0b1bc2fcfb3b73f.zip
sci-physics/uproot: add 5.4.1
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/uproot/Manifest1
-rw-r--r--sci-physics/uproot/uproot-5.4.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-physics/uproot/Manifest b/sci-physics/uproot/Manifest
index bb52077be..e8cdc29cf 100644
--- a/sci-physics/uproot/Manifest
+++ b/sci-physics/uproot/Manifest
@@ -1 +1,2 @@
DIST uproot-5.3.1.tar.gz 919910 BLAKE2B 6c138a56ecabb08905e1edde8c776c3dfae6cca3213bbc3546e7241979052178e1c9718c1fcf298573669bcc4c004806cd54ab16050405038f76f3ef356fb184 SHA512 2525f372caa3b25e3a11b170ce981ce253a7b9ca1fdb2c04b6bb1093b166d206a28e9bc22ffa19dead76870f521cee44a812cbf41a087b34fb9a3bc52c210733
+DIST uproot-5.4.1.tar.gz 935958 BLAKE2B bde5d0d5e2cef6ff35cdaea49656d2d30052a9b2f5d576e61e2df82c0a438c192db69aaffb89bd1acdb96df7aa925197ecf52ea6068bdb30d8819615b358cdfe SHA512 dc0b9b9859b7564b2027bb3f013a0fac07c665dcf32c84a3981e3fc27254598126a4bcbfb77863b419e461dec1a8c37c1e3bc181b894ea52fc141144469aedc0
diff --git a/sci-physics/uproot/uproot-5.4.1.ebuild b/sci-physics/uproot/uproot-5.4.1.ebuild
new file mode 100644
index 000000000..7d3b910d5
--- /dev/null
+++ b/sci-physics/uproot/uproot-5.4.1.ebuild
@@ -0,0 +1,30 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="ROOT I/O in pure Python and Numpy."
+HOMEPAGE="https://github.com/scikit-hep/uproot"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# way too many missing packages, isal, deflate, http servers etc
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/awkward-2.4.6[${PYTHON_USEDEP}]
+ >=dev-python/cramjam-2.5.0[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+# distutils_enable_tests pytest