aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-23 15:53:46 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-23 15:53:46 +0200
commit0d6d40c476ef48c4e25a87f97426399dfb657438 (patch)
treee9dd83a97f38cfc14bb17581dde27d102f2e8907 /sci-physics
parentsci-physics/cernlib: Drop var MY_P (diff)
downloadsci-0d6d40c476ef48c4e25a87f97426399dfb657438.tar.gz
sci-0d6d40c476ef48c4e25a87f97426399dfb657438.tar.bz2
sci-0d6d40c476ef48c4e25a87f97426399dfb657438.zip
sci-physics/particle: add 0.24.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/particle/Manifest1
-rw-r--r--sci-physics/particle/particle-0.24.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-physics/particle/Manifest b/sci-physics/particle/Manifest
index a91580388..2f92c548b 100644
--- a/sci-physics/particle/Manifest
+++ b/sci-physics/particle/Manifest
@@ -1,2 +1,3 @@
DIST particle-0.23.0.tar.gz 313512 BLAKE2B 33a0dc1cf612af8242b5080d0862f3b1e587254b46fa90f235cd6edba3919594c5077733600dfe88ad0959be889271c301324789abf0511a7fbe588942086877 SHA512 582c42beade0b28f28f3ee9f83f6d8cc75558f8a9aa5fbe3679c7aa68af40bd04f374741211d6f214bb828c24a017a89b541f780739a36d61d85a2fd5e00b530
DIST particle-0.23.1.tar.gz 313729 BLAKE2B fc35163955e065b350dfa0825612a64214baeb1f5be41404af259136e6689e23419891513c059ccdfbe2cbf5891596fccd0b0b7f283031bb3352600b5be43441 SHA512 1b4f4516357fd9725d9d5b0a481467896e93e23a8956b2ce321b9cac1d200a8ee8dd9cc1b22d940b4708f29abe3417988677ac685b78287abe10afafa79fb381
+DIST particle-0.24.0.tar.gz 314302 BLAKE2B bbb2d52a80b4d9aafaf86a3cc1b28106253bf0edfe5a6127c03242a32973feaefeb32562063e5ff0438f5df946a905d03baa36c445093ce185d3be71c10e5135 SHA512 5a73079d9120ab509162189ba5992c615fc00e00d37a6556338130739bbf53fd5db01e973cb1b509ef7ce569021c0462ac77e5fcafe40df31e5cef0a89923a2a
diff --git a/sci-physics/particle/particle-0.24.0.ebuild b/sci-physics/particle/particle-0.24.0.ebuild
new file mode 100644
index 000000000..43f1e67ca
--- /dev/null
+++ b/sci-physics/particle/particle-0.24.0.ebuild
@@ -0,0 +1,44 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="PDG particle data and identification codes"
+HOMEPAGE="https://github.com/scikit-hep/particle"
+
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/particle"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--benchmark-disable::' pyproject.toml || die
+}
+
+python_test() {
+ epytest --ignore tests/particle/test_performance.py
+}