aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 13:11:49 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:18 +0200
commit969ba769b7c38e88cc9beca7812599f2c16e70f8 (patch)
tree1a2cd9f3b39ce0c0b25f1072ba33682ae0f7955c /sci-physics/particle/particle-0.25.2.ebuild
parentsci-physics/hepunits: add 2.3.5 (diff)
downloadsci-969ba769b7c38e88cc9beca7812599f2c16e70f8.tar.gz
sci-969ba769b7c38e88cc9beca7812599f2c16e70f8.tar.bz2
sci-969ba769b7c38e88cc9beca7812599f2c16e70f8.zip
sci-physics/particle: add 0.25.2
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics/particle/particle-0.25.2.ebuild')
-rw-r--r--sci-physics/particle/particle-0.25.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-physics/particle/particle-0.25.2.ebuild b/sci-physics/particle/particle-0.25.2.ebuild
new file mode 100644
index 000000000..e5e49ea91
--- /dev/null
+++ b/sci-physics/particle/particle-0.25.2.ebuild
@@ -0,0 +1,48 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="PDG particle data and identification codes"
+HOMEPAGE="https://github.com/scikit-hep/particle"
+
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/particle"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ ' python3_{11..12})
+
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--benchmark-disable::' pyproject.toml || die
+}
+
+python_test() {
+ epytest --ignore tests/particle/test_performance.py
+}