aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-04-04 11:45:32 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-04-04 11:45:59 +0200
commitbb7405e79da76e86057725f5520201b46519e506 (patch)
treea9f15c8b2f3b9ea5cacfa68591a9d738d8674342 /sci-libs/clfft
parentdev-java/gluegen: rework ebuild starting from 2.1.4 (diff)
downloadsci-bb7405e79da76e86057725f5520201b46519e506.tar.gz
sci-bb7405e79da76e86057725f5520201b46519e506.tar.bz2
sci-bb7405e79da76e86057725f5520201b46519e506.zip
sci-libs/clfft: Replace patches by upstream patches
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-libs/clfft')
-rw-r--r--sci-libs/clfft/ChangeLog5
-rw-r--r--sci-libs/clfft/files/clfft-client_CMakeLists.patch33
-rw-r--r--sci-libs/clfft/files/clfft-scripts_perf_CMakeLists.patch34
3 files changed, 56 insertions, 16 deletions
diff --git a/sci-libs/clfft/ChangeLog b/sci-libs/clfft/ChangeLog
index 04a975b6d..e97dacd3c 100644
--- a/sci-libs/clfft/ChangeLog
+++ b/sci-libs/clfft/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Apr 2015; Marius Brehler <marbre@linux.sungazer.de>
+ files/clfft-client_CMakeLists.patch,
+ files/clfft-scripts_perf_CMakeLists.patch:
+ Replace patches by upstream patches
+
19 Feb 2015; Marius Brehler <marbre@linux.sungazer.de> clfft-9999.ebuild:
Fix SLOT operators
diff --git a/sci-libs/clfft/files/clfft-client_CMakeLists.patch b/sci-libs/clfft/files/clfft-client_CMakeLists.patch
index d779b45d9..b6cc53095 100644
--- a/sci-libs/clfft/files/clfft-client_CMakeLists.patch
+++ b/sci-libs/clfft/files/clfft-client_CMakeLists.patch
@@ -1,26 +1,41 @@
-Change the client binary's name to clfft-client.
+Upstream patch to change the client binary's name to clFFT-client.
+Remove for clfft-9999 as soon as develop branch is merged into master.
-Patch by Marius Brehler.
---- client/CMakeLists.txt
-+++ client/CMakeLists.txt
+
+From f3cbd72953094217dfeb41c4e2a328d4b4a494e0 Mon Sep 17 00:00:00 2001
+From: Marius Brehler <marius.brehler@tu-dortmund.de>
+Date: Wed, 18 Feb 2015 09:15:13 +0100
+Subject: [PATCH] Rename Client to clFFT-client
+
+---
+ src/client/CMakeLists.txt | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/client/CMakeLists.txt b/src/client/CMakeLists.txt
+index fdf209f..3b38b95 100644
+--- a/src/client/CMakeLists.txt
++++ b/src/client/CMakeLists.txt
@@ -43,15 +43,15 @@ endif( )
# Include standard OpenCL headers
include_directories( ${Boost_INCLUDE_DIRS} ${OPENCL_INCLUDE_DIRS} ../../../common ${PROJECT_BINARY_DIR}/include ../include )
-add_executable( Client ${Client.Files} )
-+add_executable( clfft-client ${Client.Files} )
++add_executable( clFFT-client ${Client.Files} )
-target_link_libraries( Client clFFT ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${DL_LIB} )
-+target_link_libraries( clfft-client clFFT ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${DL_LIB} )
++target_link_libraries( clFFT-client clFFT ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${DL_LIB} )
-set_target_properties( Client PROPERTIES VERSION ${CLFFT_VERSION} )
-set_target_properties( Client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-+set_target_properties( clfft-client PROPERTIES VERSION ${CLFFT_VERSION} )
-+set_target_properties( clfft-client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
++set_target_properties( clFFT-client PROPERTIES VERSION ${CLFFT_VERSION} )
++set_target_properties( clFFT-client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
# CPack configuration; include the executable into the package
-install( TARGETS Client
-+install( TARGETS clfft-client
++install( TARGETS clFFT-client
RUNTIME DESTINATION bin${SUFFIX_BIN}
LIBRARY DESTINATION lib${SUFFIX_LIB}
ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
+--
+2.0.4
+
diff --git a/sci-libs/clfft/files/clfft-scripts_perf_CMakeLists.patch b/sci-libs/clfft/files/clfft-scripts_perf_CMakeLists.patch
index 2976a5e63..eec9169c1 100644
--- a/sci-libs/clfft/files/clfft-scripts_perf_CMakeLists.patch
+++ b/sci-libs/clfft/files/clfft-scripts_perf_CMakeLists.patch
@@ -1,13 +1,33 @@
-Install Python scripts to /usr/share/clfft and not to /usr/bin.
+Upstream patch to install Python scripts to /usr/share/clfft and not to /usr/bin.
+Remove for clfft-9999 as soon as develop branch is merged into master.
-Patch by Marius Brehler.
---- scripts/perf/CMakeLists.txt
-+++ scripts/perf/CMakeLists.txt
-@@ -21,4 +21,4 @@ set(GRAPHING_SCRIPTS measurePerformance
+From 37b1f443e516f0a87c4a728cac8291148bb31b72 Mon Sep 17 00:00:00 2001
+From: Marius Brehler <marius.brehler@tu-dortmund.de>
+Date: Wed, 18 Feb 2015 08:59:06 +0100
+Subject: [PATCH] Install scripts/perf to share/clFFT on non WIN32
+ systems
+
+---
+ src/scripts/perf/CMakeLists.txt | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/scripts/perf/CMakeLists.txt b/src/scripts/perf/CMakeLists.txt
+index 3733789..ca45b92 100644
+--- a/src/scripts/perf/CMakeLists.txt
++++ b/src/scripts/perf/CMakeLists.txt
+@@ -20,5 +20,8 @@ set(GRAPHING_SCRIPTS measurePerformance.py
+ errorHandler.py
performanceUtility.py
)
-
+-
-install( FILES ${GRAPHING_SCRIPTS} DESTINATION bin${SUFFIX_BIN} )
\ No newline at end of file
-+install( FILES ${GRAPHING_SCRIPTS} DESTINATION share/clfft/${SUFFIX_BIN} )
++if( WIN32 )
++ install( FILES ${GRAPHING_SCRIPTS} DESTINATION bin${SUFFIX_BIN} )
++else ( )
++ install( FILES ${GRAPHING_SCRIPTS} DESTINATION share/clFFT )
++endif( )
\ No newline at end of file
+--
+2.0.4
+