aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-04-03 13:04:17 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-04-03 13:04:17 +0200
commitdd5c2cdaa5f882be9ce5f1566523b9a8a4adf7b0 (patch)
tree89bbf0859a5557be484cde98838a5427f9bcdc2b /sci-electronics
parentsci-biology/amos-short: Bump to EAPI=5, but drop KEYWORDS as SRC is unavailable (diff)
downloadsci-dd5c2cdaa5f882be9ce5f1566523b9a8a4adf7b0.tar.gz
sci-dd5c2cdaa5f882be9ce5f1566523b9a8a4adf7b0.tar.bz2
sci-dd5c2cdaa5f882be9ce5f1566523b9a8a4adf7b0.zip
sci-electronics/stage: Bump to EAPI=5
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/stage/ChangeLog5
-rw-r--r--sci-electronics/stage/Manifest2
-rw-r--r--sci-electronics/stage/stage-2.0.3.ebuild16
3 files changed, 13 insertions, 10 deletions
diff --git a/sci-electronics/stage/ChangeLog b/sci-electronics/stage/ChangeLog
index d03723fcd..d99de0a8c 100644
--- a/sci-electronics/stage/ChangeLog
+++ b/sci-electronics/stage/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-electronics/stage
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Apr 2015; Marius Brehler <marbre@linux.sungazer.de> stage-2.0.3.ebuild:
+ Bump to EAPI=5
+
07 Mar 2011; Justin Lecher <jlec@gentoo.org> stage-2.0.3.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-electronics/stage/Manifest b/sci-electronics/stage/Manifest
index 729e06304..a1f4cb210 100644
--- a/sci-electronics/stage/Manifest
+++ b/sci-electronics/stage/Manifest
@@ -1 +1 @@
-DIST stage-2.0.3.tar.bz2 451664 SHA256 7a9619f5ef633d18a11900da1e59e807547180fce4420bb9e9b4c681ddbe6c83
+DIST stage-2.0.3.tar.bz2 451664 SHA256 7a9619f5ef633d18a11900da1e59e807547180fce4420bb9e9b4c681ddbe6c83 SHA512 1126b923dce49a8ea278fba39e3af87cf79273102e7349ec5418e421853f39dbc0512e71246b503bc34d96d424512f327a501ff5c1a22ba80c585ccf07f63de3 WHIRLPOOL 555ecfcdda19a069a8e12eb916d991badc3b09130c9038efda7a242d0084fd7221d675683df45ca386abe85b75aafb07f7ecdd83328bc1591e9982fae08d0c5e
diff --git a/sci-electronics/stage/stage-2.0.3.ebuild b/sci-electronics/stage/stage-2.0.3.ebuild
index 9ed0b530c..b293697f6 100644
--- a/sci-electronics/stage/stage-2.0.3.ebuild
+++ b/sci-electronics/stage/stage-2.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI=5
inherit autotools eutils
@@ -37,25 +37,25 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
pushd docsrc
doxygen -u stage.dox || die "doxygen failed"
- touch header.html
- emake "doc" || die "emake doc failed"
+ touch header.html || die
+ emake "doc"
popd
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
if use doc; then
pushd docsrc
- emake DESTDIR="${D}" "doc-install" || die "emake doc-install failed"
+ emake DESTDIR="${D}" "doc-install"
popd
fi
- dodoc AUTHORS ChangeLog NEWS README || die
+ dodoc AUTHORS ChangeLog NEWS README
}