aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-13 02:52:03 -0500
committerHorea Christian <chr@chymera.eu>2023-01-13 02:52:03 -0500
commiteb5e69167fc45a07a43b7127e698a1555b4e99e6 (patch)
treef20f27f8fdff22af2eeced61c970466dc53bed9a /dev-python/pyout/pyout-0.7.2-r1.ebuild
parentprofiles: sci-biology/tigmint PYTHON_COMPAT updated (diff)
downloadsci-eb5e69167fc45a07a43b7127e698a1555b4e99e6.tar.gz
sci-eb5e69167fc45a07a43b7127e698a1555b4e99e6.tar.bz2
sci-eb5e69167fc45a07a43b7127e698a1555b4e99e6.zip
dev-python/pyout: supporting blessed (blessings got dropped)
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/pyout/pyout-0.7.2-r1.ebuild')
-rw-r--r--dev-python/pyout/pyout-0.7.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyout/pyout-0.7.2-r1.ebuild b/dev-python/pyout/pyout-0.7.2-r1.ebuild
new file mode 100644
index 000000000..0437e1baf
--- /dev/null
+++ b/dev-python/pyout/pyout-0.7.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1
+
+DESCRIPTION="Terminal styling for structured data"
+HOMEPAGE="https://github.com/pyout/pyout"
+SRC_URI="https://github.com/pyout/pyout/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/blessings[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${P}-blessed.patch" )
+
+python_prepare_all() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_python_prepare_all
+}