aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-26 06:22:11 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-26 06:22:11 +0100
commitab8543db8a2911e4b3d283f91fb72769e39ac03d (patch)
tree86db54c5933d7712e1050a88c0e72142f248fcac /dev-python/dpctl
parentdev-python/dpnp: drop 0.10.0, 0.11.0 (diff)
downloadsci-ab8543db8a2911e4b3d283f91fb72769e39ac03d.tar.gz
sci-ab8543db8a2911e4b3d283f91fb72769e39ac03d.tar.bz2
sci-ab8543db8a2911e4b3d283f91fb72769e39ac03d.zip
dev-python/dpctl: drop 0.13.0, 0.14.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/dpctl')
-rw-r--r--dev-python/dpctl/Manifest2
-rw-r--r--dev-python/dpctl/dpctl-0.13.0.ebuild62
-rw-r--r--dev-python/dpctl/dpctl-0.14.0.ebuild62
3 files changed, 0 insertions, 126 deletions
diff --git a/dev-python/dpctl/Manifest b/dev-python/dpctl/Manifest
index f6f26fffb..20d7c42f5 100644
--- a/dev-python/dpctl/Manifest
+++ b/dev-python/dpctl/Manifest
@@ -1,3 +1 @@
-DIST dpctl-0.13.0.gh.tar.gz 363708 BLAKE2B 82eaf296cb0aaaad1a9c23334b027d4b38ef8d580c43a6ea1fb7542b20f5511c09edf7fdd3bd98a5b48cdf55176fcaeea787c6d93ef65fc6c94004cbb0c61255 SHA512 5ddefe9671ef77e0ff507e3c92c80b147a4f19f50ee9b64dd940960e181edea16b5dbbdb990aa3dc37da80e6015979f702fba60210b8677a83780224cdd30e76
-DIST dpctl-0.14.0.gh.tar.gz 399378 BLAKE2B 3a9cbea965941c8c0a85938f0736705fd0bbdc611e02a44363a670119555ff95fbae130526caa25f42ee499d5b36c83b8c574db1b2368a1cbe7855b84fabe9f1 SHA512 37d76653112556ebeadec846cc6b156cb84e7b82bc6a9477072a3721b3a830c5fcb7d6e92e76aa7c7449547e925b07d5dda42d2777813e7d1db1d97ea852e22a
DIST dpctl-0.14.1_rc2.gh.tar.gz 409028 BLAKE2B 481be08bb6a7b1a439580d600b0e14036f10793e568314f9373ffa46daad7d3e43d33fc66c3c48ec7e3de71e9d0a7256cdfdd984c38fa7f1694dcc0227dae93f SHA512 91ab20a51893e3afc9e140ab9dfd1aa19b24e58227a001faefb9ceba6ffc4aa235214663c7456e977acf556796be097eabacc9b01b94eb42e8c70677a2f2dd9d
diff --git a/dev-python/dpctl/dpctl-0.13.0.ebuild b/dev-python/dpctl/dpctl-0.13.0.ebuild
deleted file mode 100644
index 4c240bfb1..000000000
--- a/dev-python/dpctl/dpctl-0.13.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Data Parallel Control "
-HOMEPAGE="https://github.com/IntelPython/dpctl"
-SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/scikit-build[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
- dev-util/cmake
- dev-vcs/git
- sys-devel/DPC++
-"
-
-DEPEND="
- dev-libs/level-zero
- dev-libs/opencl-icd-loader
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- sci-libs/oneDAL
- sys-devel/DPC++:0/5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.14.0-dont-fetch-level-zero.patch"
- "${FILESDIR}/${PN}-0.13.0-dont-fetch-pybind.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # DPC++ compiler required for full functionality
- export CC="${ESYSROOT}/usr/lib/llvm/intel/bin/clang"
- export CXX="${ESYSROOT}/usr/lib/llvm/intel/bin/clang++"
- export DPCPPROOT="${ESYSROOT}/usr/lib/llvm/intel"
-
- # For some reason this is required to build successfully
- mkdir -p _skbuild/linux-x86_64-3.8/setuptools/lib.linux-x86_64-cpython-38/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.8/setuptools/lib.linux-x86_64-cpython-38/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.9/setuptools/lib.linux-x86_64-cpython-39/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.9/setuptools/lib.linux-x86_64-cpython-39/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.10/setuptools/lib.linux-x86_64-cpython-310/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.10/setuptools/lib.linux-x86_64-cpython-310/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.11/setuptools/lib.linux-x86_64-cpython-311/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.11/setuptools/lib.linux-x86_64-cpython-311/dpctl || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/dpctl/dpctl-0.14.0.ebuild b/dev-python/dpctl/dpctl-0.14.0.ebuild
deleted file mode 100644
index 0bab26875..000000000
--- a/dev-python/dpctl/dpctl-0.14.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Data Parallel Control "
-HOMEPAGE="https://github.com/IntelPython/dpctl"
-SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/scikit-build[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
- dev-util/cmake
- dev-vcs/git
- sys-devel/DPC++
-"
-
-DEPEND="
- dev-libs/level-zero
- dev-libs/opencl-icd-loader
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- sci-libs/oneDAL
- sys-devel/DPC++:0/6
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}-find-opencl.patch"
- "${FILESDIR}/${P}-dont-fetch-level-zero.patch"
- "${FILESDIR}/${P}-dont-fetch-pybind.patch"
- "${FILESDIR}/${P}-include-tuple.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # DPC++ compiler required for full functionality
- export CC="${ESYSROOT}/usr/lib/llvm/intel/bin/clang"
- export CXX="${ESYSROOT}/usr/lib/llvm/intel/bin/clang++"
- export DPCPPROOT="${ESYSROOT}/usr/lib/llvm/intel"
-
- # Build system reads version from git tag
- git init -q || die
- git config --global user.email "larry@gentoo.org" || die
- git config --global user.name "Larry the Cow" || die
- git add . || die
- git commit -qm "init" || die
- git tag -a "${PV}" -m "${PN} version ${PV}" || die
-
- distutils-r1_python_prepare_all
-}