aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-05-07 22:32:02 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 14:20:46 +0200
commitbbb29d63503456863de7a523a9e260073427190b (patch)
tree18068bbf232661f45d0228828e820e498edc40ab
parentsci-physics/evtgen: new package, 02.02.01 (diff)
downloadsci-bbb29d63503456863de7a523a9e260073427190b.tar.gz
sci-bbb29d63503456863de7a523a9e260073427190b.tar.bz2
sci-bbb29d63503456863de7a523a9e260073427190b.zip
sci-physics/herwig: new package, add 7.3.0
Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/sci/pull/1271 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/herwig/Manifest1
-rw-r--r--sci-physics/herwig/herwig-7.3.0.ebuild65
-rw-r--r--sci-physics/herwig/metadata.xml26
3 files changed, 92 insertions, 0 deletions
diff --git a/sci-physics/herwig/Manifest b/sci-physics/herwig/Manifest
new file mode 100644
index 000000000..01457a201
--- /dev/null
+++ b/sci-physics/herwig/Manifest
@@ -0,0 +1 @@
+DIST herwig-7.3.0.tar.bz2 4264666 BLAKE2B 33b9bbce0f69f5c73ddc16c19d98323ea60d89fb00dacdbb069440b574721bd44eee6528d78b2e9aaf3bea1d59e5112ca3f4c780032da9807e6d2a676ebacde5 SHA512 29254026c715550d0cd537a33ac37d17ab93279087901e284fea4209091fd3f84244ecbd223e0fe3fd30923c755d630cf066b17bc35288c5f3ab6f4e8d4a5bbe
diff --git a/sci-physics/herwig/herwig-7.3.0.ebuild b/sci-physics/herwig/herwig-7.3.0.ebuild
new file mode 100644
index 000000000..5576f3cf7
--- /dev/null
+++ b/sci-physics/herwig/herwig-7.3.0.ebuild
@@ -0,0 +1,65 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit fortran-2 python-single-r1 autotools
+
+MY_PN="Herwig"
+MY_PF=${MY_PN}-${PV}
+
+DESCRIPTION="Herwig is a multi-purpose particle physics event generator."
+HOMEPAGE="https://herwig.hepforge.org/"
+SRC_URI="https://herwig.hepforge.org/downloads?f=${MY_PF}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="GPL-3+"
+SLOT="7"
+KEYWORDS="~amd64"
+IUSE="+pythia" # madgraph openloops gosam vbfnlo njet
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ >=dev-libs/boost-1.62
+ >=sci-libs/gsl-2.6
+ sci-physics/fastjet
+ sci-physics/lhapdf-sets[lhapdf_sets_ct14lo,lhapdf_sets_ct14nlo]
+ >=sci-physics/lhapdf-6.1.6[python(+),${PYTHON_SINGLE_USEDEP}]
+ >=sci-physics/thepeg-2.1.0[lhapdf,fastjet,-hepmc2(-),hepmc3(-),rivet(-)]
+ >=sci-physics/evtgen-02.02.00[pythia]
+ pythia? ( sci-physics/pythia:8= )
+ ${PYTHON_DEPS}
+"
+# madgraph? ( sci-physics/madgraph5 )
+# openloops? ( sci-physics/openloops )
+# gosam? ( sci-physics/gosam )
+# vbfnlo? ( sci-physics/vbfnlo )
+# njet? ( sci-physics/njet )
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# https://herwig.hepforge.org/tutorials/installation/manual.html
+# Minimal installation for now
+src_configure() {
+ CONFIG_SHELL=${ESYSROOT}/bin/bash \
+ econf \
+ --with-evtgen="${EPREFIX}"/usr \
+ --with-fastjet="${EPREFIX}"/usr \
+ --with-thepeg="${EPREFIX}"/usr \
+ --with-boost="${EPREFIX}"/usr \
+ $(use_with pythia pythia "${EPREFIX}"/usr) \
+ # $(use_with madgraph madgraph "${EPREFIX}"/opt/MadGraph5/ ) \
+ # $(use_with openloops openloops "${EPREFIX}"/opt/OpenLoops2/ ) \
+ # $(use_with gosam gosam "${EPREFIX}"/usr) \
+ # $(use_with vbfnlo vbfnlo "${EPREFIX}"/usr) \
+ # $(use_with njet njet "${EPREFIX}"/usr)
+}
+
+src_install() {
+ default
+}
diff --git a/sci-physics/herwig/metadata.xml b/sci-physics/herwig/metadata.xml
new file mode 100644
index 000000000..804bc3361
--- /dev/null
+++ b/sci-physics/herwig/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ Herwig provides significantly improved and extended physics capabilities when compared to both its predecessors, HERWIG 6 and Herwig++ 2, while keeping the key model motivations such as coherent parton showers (including angular-ordered and dipole-based evolution), the cluster hadronization model, an eikonal multiple-interaction model, highly flexible BSM capabilities and improved perturbative input using next-to-leading order QCD.
+ </longdescription>
+ <use>
+ <flag name="pythia">Build with pythia support </flag>
+<!--
+ <flag name="openloops">Build with openloops support </flag>
+ <flag name="gosam">Build with gosam support </flag>
+ <flag name="madgraph">Build with madgraph support </flag>
+ <flag name="vbfnlo">Build with vbfnlo support </flag>
+ <flag name="njet">Build with njet support </flag>
+-->
+ </use>
+</pkgmetadata>