aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 14:51:34 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:33 +0200
commit2476e6e6009db0cc4806b335aba6cc5bd335f4de (patch)
treeeab242da6ef2a8b1c48b97998d2daeb4a212289d
parentdev-python/histoprint: add 2.5.0 (diff)
downloadsci-2476e6e6009db0cc4806b335aba6cc5bd335f4de.tar.gz
sci-2476e6e6009db0cc4806b335aba6cc5bd335f4de.tar.bz2
sci-2476e6e6009db0cc4806b335aba6cc5bd335f4de.zip
sci-physics/mplhep: new package, add 0.3.53
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/mplhep/Manifest1
-rw-r--r--sci-physics/mplhep/metadata.xml19
-rw-r--r--sci-physics/mplhep/mplhep-0.3.53.ebuild47
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-physics/mplhep/Manifest b/sci-physics/mplhep/Manifest
new file mode 100644
index 000000000..34a7cdb3d
--- /dev/null
+++ b/sci-physics/mplhep/Manifest
@@ -0,0 +1 @@
+DIST mplhep-0.3.53.tar.gz 1520164 BLAKE2B 282455c7c9291641d0bf59a1b14a3d899d0ca3af40ad437c6b2238040b953eea7eaa51011f89a5e12a13c26856a5850122870961fa19621f7a090700627c89c3 SHA512 e3496bedbd9310271a01817374a6b006322f04fcc98ed9d31cb066cc79d9cc907c5541bf4acbe97347ae8c742116c5cba9a73166fd54c35d8fb91808a07871ad
diff --git a/sci-physics/mplhep/metadata.xml b/sci-physics/mplhep/metadata.xml
new file mode 100644
index 000000000..e8b27c898
--- /dev/null
+++ b/sci-physics/mplhep/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ A set of helpers for matplotlib to more easily produce plots typically needed in HEP as well as style them in way that's compatible with current collaboration requirements (ROOT-like plots for CMS, ATLAS, LHCb, ALICE).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">mplhep</remote-id>
+ <remote-id type="github">scikit-hep/mplhep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/mplhep/mplhep-0.3.53.ebuild b/sci-physics/mplhep/mplhep-0.3.53.ebuild
new file mode 100644
index 000000000..ed147722d
--- /dev/null
+++ b/sci-physics/mplhep/mplhep-0.3.53.ebuild
@@ -0,0 +1,47 @@
+EAPI=8
+
+# wait for pytest-mpl before adding 3_13
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="Histogram plots using matplotlib and HEP compatible styling ROOT."
+HOMEPAGE="
+ https://mplhep.readthedocs.io
+ https://github.com/scikit-hep/mplhep
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/matplotlib-3.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+ sci-physics/mplhep-data[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/uhi-0.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/boost-histogram[${PYTHON_USEDEP}]
+ dev-python/hist[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0[${PYTHON_USEDEP}]
+ sci-physics/scikit-hep-testdata[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.1.0[${PYTHON_USEDEP}]
+ sci-physics/uproot[${PYTHON_USEDEP}]
+ )
+"
+
+# we do not want to care about old uproot4
+EPYTEST_DESELECT=(
+ 'tests/test_inputs.py::test_inputs_uproot'
+ 'tests/test_inputs.py::test_uproot_versions[png]'
+ 'tests/test_inputs.py::test_uproot_versions[pdf]'
+ 'tests/test_inputs.py::test_uproot_versions[svg]'
+)
+
+distutils_enable_tests pytest