aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-22 04:33:37 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-22 04:38:51 -0400
commit873e8a4748ed52fc33a3e96011b3b246c602277d (patch)
tree736c265a51b3bead3af1c5190cca18b7ed28881a
parentlibsandbox: fix ppc ptrace return value setting (diff)
downloadsandbox-873e8a4748ed52fc33a3e96011b3b246c602277d.tar.gz
sandbox-873e8a4748ed52fc33a3e96011b3b246c602277d.tar.bz2
sandbox-873e8a4748ed52fc33a3e96011b3b246c602277d.zip
Revert "Remove leftover generated Makefiles from the repo (sic!)"
This reverts commit 53ffbaeb24f6ee22a2dcd70fad29c86a4dd863c2. These files are supposed to be in here. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--libsandbox/Makefile4
-rw-r--r--libsbutil/Makefile4
-rw-r--r--src/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/libsandbox/Makefile b/libsandbox/Makefile
new file mode 100644
index 0000000..2db82ff
--- /dev/null
+++ b/libsandbox/Makefile
@@ -0,0 +1,4 @@
+# Helper for developers.
+all libsandbox libsandbox.la: libsandbox/libsandbox.la ;
+clean: ; rm -f *.o *.l[ao] .libs/*
+%: ; $(MAKE) -C .. $@
diff --git a/libsbutil/Makefile b/libsbutil/Makefile
new file mode 100644
index 0000000..f5638c7
--- /dev/null
+++ b/libsbutil/Makefile
@@ -0,0 +1,4 @@
+# Helper for developers.
+all libsbutil libsbutil.la: libsbutil/libsbutil.la ;
+clean: ; rm -f *.o *.l[ao] .libs/*
+%: ; $(MAKE) -C .. $@
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 0000000..4b2bc35
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,4 @@
+# Helper for developers.
+all sandbox: src/sandbox ;
+clean: ; rm -f *.o *.l[ao] .libs/* sandbox
+%: ; $(MAKE) -C .. $@