aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:22:03 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:28 +0300
commit73c7d1d23b25acb18e36f8acade1dfc52c0f4de3 (patch)
tree412acd99cc1e4c57e616776016e657bb8e39aa75
parentx11-misc/pcmanfm-qt: add 2.0.0 (diff)
downloadqt-73c7d1d23b25acb18e36f8acade1dfc52c0f4de3.tar.gz
qt-73c7d1d23b25acb18e36f8acade1dfc52c0f4de3.tar.bz2
qt-73c7d1d23b25acb18e36f8acade1dfc52c0f4de3.zip
media-gfx/lximage-qt: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--media-gfx/lximage-qt/Manifest1
-rw-r--r--media-gfx/lximage-qt/lximage-qt-2.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
new file mode 100644
index 00000000..4d60d616
--- /dev/null
+++ b/media-gfx/lximage-qt/Manifest
@@ -0,0 +1 @@
+DIST lximage-qt-2.0.0.tar.xz 847796 BLAKE2B 4a81730bfc71b3746f7df9a357feb2480c4d4ed1462b70349113fa2b0b4e2c77471205549366cba99236d836753235cb929a6c98b3c08c346346a89ba70e3935 SHA512 f0d8b810915102ecd2cff0b78049056eb6eb3e7b7112bac13742f780d1cacc51fce12114dacc47ca6846d77d01bf21efca0666b1d5f6ca467a6e07deefeee83a
diff --git a/media-gfx/lximage-qt/lximage-qt-2.0.0.ebuild b/media-gfx/lximage-qt/lximage-qt-2.0.0.ebuild
new file mode 100644
index 00000000..5a929584
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-2.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Image Viewer"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-6.6:6[dbus,gui,network,widgets]
+ >=dev-qt/qtsvg-6.6:6
+ media-libs/libexif
+ =x11-libs/libfm-qt-${MY_PV}*:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}