summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/03_all_libdir.patch')
-rw-r--r--patches/03_all_libdir.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index dfafeb2..de82e44 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -71,7 +71,7 @@
'data' : '{userbase}',
--- Lib/test/test_site.py
+++ Lib/test/test_site.py
-@@ -242,10 +242,10 @@
+@@ -247,10 +247,10 @@
elif os.sep == '/':
# OS X non-framwework builds, Linux, FreeBSD, etc
self.assertEqual(len(dirs), 2)
@@ -108,7 +108,7 @@
#
--- Modules/getpath.c
+++ Modules/getpath.c
-@@ -129,7 +129,7 @@
+@@ -108,7 +108,7 @@
static char exec_prefix[MAXPATHLEN+1];
static char progpath[MAXPATHLEN+1];
static char *module_search_path = NULL;
@@ -117,7 +117,7 @@
static void
reduce(char *dir)
-@@ -543,7 +543,7 @@
+@@ -522,7 +522,7 @@
}
else
strncpy(zip_path, PREFIX, MAXPATHLEN);
@@ -126,7 +126,7 @@
bufsz = strlen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -553,7 +553,7 @@
+@@ -532,7 +532,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
@@ -137,7 +137,7 @@
--- setup.py
+++ setup.py
-@@ -452,7 +452,7 @@
+@@ -468,7 +468,7 @@
global disable_ssl
# Ensure that /usr/local is always used
if not cross_compiling:
@@ -146,7 +146,7 @@
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
-@@ -519,8 +519,7 @@
+@@ -535,8 +535,7 @@
):
add_dir_to_list(inc_dirs, d)
for d in (
@@ -156,7 +156,7 @@
):
add_dir_to_list(lib_dirs, d)
exts = []
-@@ -774,11 +773,11 @@
+@@ -794,11 +793,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -170,7 +170,7 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -1044,8 +1043,7 @@
+@@ -1064,8 +1063,7 @@
# check lib directories parallel to the location of the header
db_dirs_to_check = [
@@ -180,7 +180,7 @@
]
if host_platform != 'darwin':
-@@ -1158,10 +1156,8 @@
+@@ -1178,10 +1176,8 @@
if sqlite_incdir:
sqlite_dirs_to_check = [
@@ -193,7 +193,7 @@
]
sqlite_libfile = self.compiler.find_library_file(
sqlite_dirs_to_check + lib_dirs, 'sqlite3')
-@@ -1933,15 +1929,14 @@
+@@ -1953,15 +1949,14 @@
added_lib_dirs.append('/usr/openwin/lib')
elif os.path.exists('/usr/X11R6/include'):
include_dirs.append('/usr/X11R6/include')