aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-24 20:24:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-24 20:58:55 +0300
commit5c1aa542b04e983200ed4805c513bbcfe7e3628c (patch)
tree3fd0a77615b25ab8e9a0543359a8f5aed66cf161
parentremove mk_cpy_loadable_testcase (diff)
downloadsnakeoil-5c1aa542b04e983200ed4805c513bbcfe7e3628c.tar.gz
snakeoil-5c1aa542b04e983200ed4805c513bbcfe7e3628c.tar.bz2
snakeoil-5c1aa542b04e983200ed4805c513bbcfe7e3628c.zip
build: simplify after cython removal
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--.github/workflows/release.yml15
-rw-r--r--pyproject.toml2
-rw-r--r--requirements/build.txt1
-rw-r--r--requirements/dist.txt1
-rw-r--r--requirements/docs.txt1
-rw-r--r--setup.cfg4
-rwxr-xr-xsetup.py2
7 files changed, 3 insertions, 23 deletions
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
index 4c559762..b8ffb0c5 100644
--- a/.github/workflows/release.yml
+++ b/.github/workflows/release.yml
@@ -39,19 +39,8 @@ jobs:
# run in-place build so wheel deps use release versions
python setup.py build_py -i
- - name: Build wheels
- uses: joerick/cibuildwheel@v2.8.1
- with:
- output-dir: dist
- env:
- CIBW_BUILD: cp38-* cp39-* cp310-* cp311-* pp39-*
- CIBW_ARCHS_LINUX: x86_64
- CIBW_MANYLINUX_X86_64_IMAGE: manylinux_2_24
- CIBW_PRERELEASE_PYTHONS: True
- CIBW_BEFORE_BUILD: pip install -r {project}/requirements/dist.txt
- CIBW_BEFORE_TEST: pip install -r {project}/requirements/test.txt
- CIBW_ENVIRONMENT: PY_COLORS=1
- CIBW_TEST_COMMAND: pytest -v {project}/tests
+ - name: Build wheel
+ run: python setup.py bdist_wheel
- name: Output dist file info
run: |
diff --git a/pyproject.toml b/pyproject.toml
index 0de0785e..34cb6b5b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["cython", "setuptools", "wheel"]
+requires = ["setuptools", "wheel"]
build-backend = "setuptools.build_meta"
[tool.pytest.ini_options]
diff --git a/requirements/build.txt b/requirements/build.txt
deleted file mode 100644
index 15bf715a..00000000
--- a/requirements/build.txt
+++ /dev/null
@@ -1 +0,0 @@
-cython>=0.29.28
diff --git a/requirements/dist.txt b/requirements/dist.txt
index 17e3a6da..ec031163 100644
--- a/requirements/dist.txt
+++ b/requirements/dist.txt
@@ -1,5 +1,4 @@
# deps for building sdist/wheels for pypi
--r build.txt
-r install.txt
-r docs.txt
wheel
diff --git a/requirements/docs.txt b/requirements/docs.txt
index 79e24598..67848fc2 100644
--- a/requirements/docs.txt
+++ b/requirements/docs.txt
@@ -1,4 +1,3 @@
--r build.txt
-r install.txt
sphinx
diff --git a/setup.cfg b/setup.cfg
index ccd55846..446d8365 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,9 +6,5 @@ source-dir = doc
build-dir = build/sphinx
all_files = 1
-[build_ext]
-# uncomment if you don't want to build the extension modules
-#build-optional=false
-
[tool:pytest]
testpaths = tests
diff --git a/setup.py b/setup.py
index 071b60ac..9aae7131 100755
--- a/setup.py
+++ b/setup.py
@@ -18,10 +18,8 @@ setup(**dict(
license='BSD',
author='Tim Harder',
author_email='radhermit@gmail.com',
- ext_modules=pkgdist.cython_exts(),
cmdclass=dict(
pkgdist_cmds,
- build_ext=pkgdist.build_ext,
),
classifiers=[
'Intended Audience :: Developers',