aboutsummaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2006-02-22 02:59:00 -0800
committerBrian Harring <ferringb@gmail.com>2006-02-22 02:59:00 -0800
commit646f3c48fcb742d5f34c606b23a0d4237f87539b (patch)
tree05cf272f957d13bbb88db1a27368bc8613c53cc9 /data
parentreplace interface/operation added; added start method for initiating locking. (diff)
downloadpkgcore-646f3c48fcb742d5f34c606b23a0d4237f87539b.tar.gz
pkgcore-646f3c48fcb742d5f34c606b23a0d4237f87539b.tar.bz2
pkgcore-646f3c48fcb742d5f34c606b23a0d4237f87539b.zip
merge of marien zwart's configuration rewrite (savior-config-rewrite repo); couple of tweaks in importing it,
modified portage.test.config.test_dhcpformat so that it skips each test if pyparsing isn't available; aside from that fix up in portage.ebuild.profile to correct an old import of portage.config.central to get list_parser
Diffstat (limited to 'data')
-rw-r--r--data/conf_default_types36
1 files changed, 21 insertions, 15 deletions
diff --git a/data/conf_default_types b/data/conf_default_types
index b64191d8..4aa35604 100644
--- a/data/conf_default_types
+++ b/data/conf_default_types
@@ -79,22 +79,29 @@
[profile]
-list = %(default_incrementals)s package.keywords package.use package.unmask package.mask
-defaults = class incrementals
-incrementals = %(default_incrementals)s
+list = %(default_incrementals)s profile_incrementals package.keywords package.use package.unmask package.mask
+defaults = class profile_incrementals
+incrementals = %(default_incrementals)s
+profile_incrementals = %(default_incrementals)s
class = portage.ebuild.profiles.OnDiskProfile
-required = class incrementals base_repo profile
+required = class profile_incrementals base_repo profile
section_ref = base_repo
-positional = base_repo profile incrementals
+positional = base_repo profile profile_incrementals
+str = profile
[domain]
#instantiate = portage.config.parser.domain
-required = repositories profile root class incrementals ACCEPT_LICENSE vdb fetcher
-section_ref = repositories profile vdb fetcher
-list = %(default_incrementals)s %(package_filters)s package.unmask repositories vdb bashrc
+required = repositories profile root class domain_incrementals ACCEPT_LICENSE vdb fetcher
+section_ref = profile fetcher
+section_refs = repositories vdb
+list = %(default_incrementals)s %(package_filters)s package.unmask bashrc domain_incrementals
+str = root CHOST CFLAGS PATH PORTAGE_TMPDIR DISTCC_PATH DISTCC_DIR CCACHE_PATH CCACHE_DIR
+# XXX is this right
+bool = default
incrementals = %(default_incrementals)s
-defaults = class root incrementals ACCEPT_LICENSE PORTAGE_TMPDIR PATH DISTCC_PATH DISTCC_DIR CCACHE_PATH CCACHE_DIR
+domain_incrementals = %(default_incrementals)s
+defaults = class root domain_incrementals ACCEPT_LICENSE PORTAGE_TMPDIR PATH DISTCC_PATH DISTCC_DIR CCACHE_PATH CCACHE_DIR
class = portage.config.domain.domain
root = /
ACCEPT_LICENSE =
@@ -105,7 +112,7 @@ DISTCC_DIR = ".distcc"
CCACHE_PATH = "/usr/lib/ccache/bin"
CCACHE_DIR = "/var/tmp/ccache"
PATH = %(default_path)s
-positional = incrementals root profile repositories vdb
+positional = domain_incrementals root profile repositories vdb
[repo]
@@ -113,24 +120,22 @@ required = class location
defaults = class
class = portage.ebuild.repository
section_ref = cache sync sync_cache fetcher
+str = location
[cache]
required = class location label auxdbkeys
-defaults = class auxdbkeys location label readonly
+defaults = class auxdbkeys location readonly
class = portage.cache.flat_list.database
auxdbkeys = %(metadata_keys)s
location = %(cache_base_loc)s
readonly = false
list = auxdbkeys
+str = location label
positional = location label auxdbkeys
bool = readonly
-[exec]
-autoexec = true
-
-
[sync]
required = class url
defaults = class
@@ -143,6 +148,7 @@ bool = userpriv
list = required_chksums
defaults = class command userpriv required_chksums
positional = distdir command required_chksums
+str = distdir command
class = portage.fetch.custom.fetcher
command = "/usr/bin/wget -c -t 5 --passive-ftp -P '${DISTDIR}' '${URI}'"
required_chksums = all