aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'testdata')
-rw-r--r--testdata/data/repos/standalone/BadCommandsCheck/BannedPhaseCall/expected.json1
-rw-r--r--testdata/repos/standalone/BadCommandsCheck/BannedPhaseCall/BannedPhaseCall-0.ebuild14
2 files changed, 15 insertions, 0 deletions
diff --git a/testdata/data/repos/standalone/BadCommandsCheck/BannedPhaseCall/expected.json b/testdata/data/repos/standalone/BadCommandsCheck/BannedPhaseCall/expected.json
new file mode 100644
index 00000000..cf55baad
--- /dev/null
+++ b/testdata/data/repos/standalone/BadCommandsCheck/BannedPhaseCall/expected.json
@@ -0,0 +1 @@
+{"__class__": "BannedPhaseCall", "category": "BadCommandsCheck", "package": "BannedPhaseCall", "version": "0", "line": "pkg_postinst", "lineno": 13}
diff --git a/testdata/repos/standalone/BadCommandsCheck/BannedPhaseCall/BannedPhaseCall-0.ebuild b/testdata/repos/standalone/BadCommandsCheck/BannedPhaseCall/BannedPhaseCall-0.ebuild
new file mode 100644
index 00000000..c7177c07
--- /dev/null
+++ b/testdata/repos/standalone/BadCommandsCheck/BannedPhaseCall/BannedPhaseCall-0.ebuild
@@ -0,0 +1,14 @@
+EAPI=8
+
+DESCRIPTION="Ebuild calls phase function directly"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+SLOT="0"
+LICENSE="BSD"
+
+pkg_postinst() {
+ echo "something"
+}
+
+pkg_postrm() {
+ pkg_postinst
+}