aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-01 23:10:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-01 23:10:53 +0300
commitef0ee73cdcfe27dc27e208afe36060e0e52a3165 (patch)
tree118c9dfeb0c14d34d79fe29301959c2f0e24f0ea /testdata/repos
parentDuplicateFunctionDefinition: new check for duplicate global functions (diff)
downloadpkgcheck-ef0ee73cdcfe27dc27e208afe36060e0e52a3165.tar.gz
pkgcheck-ef0ee73cdcfe27dc27e208afe36060e0e52a3165.tar.bz2
pkgcheck-ef0ee73cdcfe27dc27e208afe36060e0e52a3165.zip
BannedEapiCommand: check for has_version --host-root
Catch ``has_version --host-root`` and ``best_version --host-root`` calls, which are not allowed in EAPI>=7. Resolves: https://github.com/pkgcore/pkgcheck/issues/630 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'testdata/repos')
-rw-r--r--testdata/repos/standalone/BadCommandsCheck/BannedEapiCommand/BannedEapiCommand-1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/testdata/repos/standalone/BadCommandsCheck/BannedEapiCommand/BannedEapiCommand-1.ebuild b/testdata/repos/standalone/BadCommandsCheck/BannedEapiCommand/BannedEapiCommand-1.ebuild
new file mode 100644
index 00000000..ea4fb45b
--- /dev/null
+++ b/testdata/repos/standalone/BadCommandsCheck/BannedEapiCommand/BannedEapiCommand-1.ebuild
@@ -0,0 +1,13 @@
+EAPI=7
+
+DESCRIPTION="Ebuild using banned has_version"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+SLOT="0"
+LICENSE="BSD"
+
+src_install() {
+ if has_version --host-root stub/stub1; then
+ :
+ fi
+ H=$(best_version --host-root stub/stub1:2)
+}