aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-09 20:25:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-09 20:25:52 +0200
commitd2a5afc73f39786877d7a3353be94f4cbcb5a2a2 (patch)
treed25f7efea5ec1a57010479084038d45f999bf43b /testdata/repos
parentadd __main__.py file (diff)
downloadpkgcheck-d2a5afc73f39786877d7a3353be94f4cbcb5a2a2.tar.gz
pkgcheck-d2a5afc73f39786877d7a3353be94f4cbcb5a2a2.tar.bz2
pkgcheck-d2a5afc73f39786877d7a3353be94f4cbcb5a2a2.zip
MissingInherits: don't show for functions defined in ebuild
Resolves: https://github.com/pkgcore/pkgcheck/issues/513 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'testdata/repos')
-rw-r--r--testdata/repos/eclass/InheritsCheck/MissingInherits/MissingInherits-2.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/testdata/repos/eclass/InheritsCheck/MissingInherits/MissingInherits-2.ebuild b/testdata/repos/eclass/InheritsCheck/MissingInherits/MissingInherits-2.ebuild
new file mode 100644
index 00000000..9aa0432e
--- /dev/null
+++ b/testdata/repos/eclass/InheritsCheck/MissingInherits/MissingInherits-2.ebuild
@@ -0,0 +1,15 @@
+EAPI=7
+
+DESCRIPTION="Ebuild missing an eclass inherit"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+SLOT="0"
+LICENSE="BSD"
+
+src_prepare() {
+ inherit_public_func
+ unset EBUILD_TEST
+}
+
+inherit_public_func() {
+ echo "inherit_public_func"
+}