aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-13 23:14:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-19 18:35:07 +0200
commit3af5138d54c975ae9ea48d14cfc00726e0f77ac1 (patch)
tree6bee4b7e28fd8efb1ca58d572e0e5c701382dc3c /Makefile
parentscan: add support for NOCOLOR to disable colors (diff)
downloadpkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.tar.gz
pkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.tar.bz2
pkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.zip
setup.py: move to pure setuptools
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 00000000..3eb6e2e4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+PYTHON ?= python
+SPHINX_BUILD ?= $(PYTHON) -m sphinx.cmd.build
+
+.PHONY: man html
+man html:
+ $(SPHINX_BUILD) -a -b $@ doc build/sphinx/$@
+
+.PHONY: sdist wheel
+sdist wheel:
+ $(PYTHON) -m build --$@
+
+.PHONY: clean
+clean:
+ $(RM) -r build/sphinx doc/api doc/generated dist