summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-09-05 13:49:16 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-09-05 13:49:16 +0000
commit937866b3c741c56a1f06da5487bb79436e6d7471 (patch)
tree94f28b6021ddae1c81da8046d3795499f92c85d0
parentMoved in portage (diff)
downloadnx-937866b3c741c56a1f06da5487bb79436e6d7471.tar.gz
nx-937866b3c741c56a1f06da5487bb79436e6d7471.tar.bz2
nx-937866b3c741c56a1f06da5487bb79436e6d7471.zip
Preliminary nxweb, bug #191176
svn path=/testing/; revision=190
-rw-r--r--net-misc/nxweb/Manifest2
-rw-r--r--net-misc/nxweb/nxweb-3.0.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/nxweb/Manifest b/net-misc/nxweb/Manifest
new file mode 100644
index 0000000..a6ed744
--- /dev/null
+++ b/net-misc/nxweb/Manifest
@@ -0,0 +1,2 @@
+DIST nxplugin-3.0.0-5.i386.tar.gz 13875502 RMD160 f2faa7dbab4e869a04ee059cc1bd25299b6cc7de SHA1 ea2fa4ee84ef8227a6f125343568b679296be116 SHA256 6e0801cf80084450d22a3558a22879179aeed215c7dad827f32f750d10d914e5
+EBUILD nxweb-3.0.0.ebuild 1004 RMD160 652f2c1ed4661cc0e5a79252fdd3926e094493a5 SHA1 46e7f2917da67a3ebc53fccc648f7c51e13d3298 SHA256 cbf5fe1c32d9936d0bb3dd3810e6c3f3369334c68c8558f89433ad4212a44430
diff --git a/net-misc/nxweb/nxweb-3.0.0.ebuild b/net-misc/nxweb/nxweb-3.0.0.ebuild
new file mode 100644
index 0000000..009d506
--- /dev/null
+++ b/net-misc/nxweb/nxweb-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp
+
+DESCRIPTION="web companion client for NoMachine NX servers"
+HOMEPAGE="http://www.nomachine.com/"
+
+SRC_URI="http://64.34.161.181/download/${PV}/Linux/nxplugin-${PV}-5.i386.tar.gz"
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/nxserver-freeedition-3.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ webapp_src_preinst
+
+ einfo "Patching nxapplet.html with server hostname: ${VHOST_HOSTNAME}"
+ sed -i -e "s|http://webserver|http://${VHOST_HOSTNAME}/${PN}|" usr/NX/share/plugin/nxapplet.html
+ [ "$VHOST_HOSTNAME" = localhost ] && ewarn "Server hostname is localhost, the plugin will not be usable from remote hosts"
+
+ cp -R usr/NX/share/* ${D}/${MY_HTDOCSDIR}
+
+ #TODO: webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ # Note to the user that she can access the client at http://localhost/nxweb/plugin/nxapplet.html
+
+ webapp_src_install
+}