summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2009-11-29 19:51:29 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2009-11-29 19:51:29 -0100
commit865a1221ca70cf184902902971cc7bec2c80dfd1 (patch)
treeda7c46d8f5d5af3799b1f747d3a91449374ec22c
parentAdded experimental mysql-5.0.88 ebuild with no Percona patches. (diff)
downloadmysql-865a1221ca70cf184902902971cc7bec2c80dfd1.tar.gz
mysql-865a1221ca70cf184902902971cc7bec2c80dfd1.tar.bz2
mysql-865a1221ca70cf184902902971cc7bec2c80dfd1.zip
Initial bump to mysql-5.1.41.
This is not ready for use yet!
-rw-r--r--dev-db/mysql/ChangeLog10
-rw-r--r--dev-db/mysql/Manifest2
-rw-r--r--dev-db/mysql/mysql-5.1.41.ebuild148
-rw-r--r--profiles/package.mas4
4 files changed, 164 insertions, 0 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
new file mode 100644
index 0000000..7512aa4
--- /dev/null
+++ b/dev-db/mysql/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/mysql
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mysql-5.1.41 (29 Nov 2009)
+
+ 29 Nov 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +mysql-5.1.41.ebuild:
+ Initial bump to mysql-5.1.41.
+
diff --git a/dev-db/mysql/Manifest b/dev-db/mysql/Manifest
index 31d7cc6..9538319 100644
--- a/dev-db/mysql/Manifest
+++ b/dev-db/mysql/Manifest
@@ -4,5 +4,7 @@ AUX my.cnf-4.1 4235 RMD160 ca04e2e667322e99c29be59064c7a6ecaa4e1e4c SHA1 babc799
AUX mysql.init 886 RMD160 26b8aa45af3f930db01f0db731865b9293626fb1 SHA1 d7d99a3f45fa807d1fb57ab04b35800a69cae430 SHA256 2d7faf6d88fd13e5c10368a20074fdb59554635f8b1fd17e088d82208e611c12
DIST mysql-5.0.87.tar.gz 22231820 RMD160 b6a6bf715e4b9b71d62ecb13d2e5b47b53806379 SHA1 7cca720e81b0fce2bf54e8b8a35f126af445fc47 SHA256 47b324b4dccc06bd2089b2e029a762a4c15b985ee0d31a0e90ae85ac26b5c1c2
DIST mysql-5.0.88.tar.gz 22932765 RMD160 a3ba4bd04e573b4a0bab073f36eec3ff44348ae6 SHA1 2dc7a462eaca1452eefd334888a6c40022deb352 SHA256 c7b0265134fae6bcb254ae9ae97f580849e4ac491c2bfe136632abe74cb2f84a
+DIST mysql-5.1.41.tar.gz 23026814 RMD160 f99d17a2bb43fc45222c7015a3b65c6b4f686129 SHA1 04f7cf87419ca233c2508c2912d72548767b7e2c SHA256 5cb721db43a5f61710d8503813adef335cb1b738c7164e3d7d2a9681af8dbc16
EBUILD mysql-5.0.87.ebuild 4866 RMD160 c98ed085af8fd08cbc8ef9b47401e6e65c4355e8 SHA1 43b27ad2d42e83af9789bf5180aeb0ade39d6867 SHA256 a57c654b9c484cf1a303300bb305a6e3ad69448cca974ae06d83a499e8a98701
EBUILD mysql-5.0.88.ebuild 4866 RMD160 c98ed085af8fd08cbc8ef9b47401e6e65c4355e8 SHA1 43b27ad2d42e83af9789bf5180aeb0ade39d6867 SHA256 a57c654b9c484cf1a303300bb305a6e3ad69448cca974ae06d83a499e8a98701
+EBUILD mysql-5.1.41.ebuild 4866 RMD160 c98ed085af8fd08cbc8ef9b47401e6e65c4355e8 SHA1 43b27ad2d42e83af9789bf5180aeb0ade39d6867 SHA256 a57c654b9c484cf1a303300bb305a6e3ad69448cca974ae06d83a499e8a98701
diff --git a/dev-db/mysql/mysql-5.1.41.ebuild b/dev-db/mysql/mysql-5.1.41.ebuild
new file mode 100644
index 0000000..014711d
--- /dev/null
+++ b/dev-db/mysql/mysql-5.1.41.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84-r1.ebuild,v 1.7 2009/11/09 18:00:20 fauli Exp $
+
+MY_EXTRAS_VER="live"
+EAPI=2
+
+inherit toolchain-funcs mysql
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# Define the mysql-extras source
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-4 >=sys-devel/gcc-apple-4 )"
+RDEPEND=""
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='berkdb cluster embedded extraengine perl ssl community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mysql-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ emake check || die "make check failed"
+ if ! use "minimal" ; then
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.4[3-9]|5.0.[56]*|5.0.70)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.43-70 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # New test was broken in first time
+ # Upstream bug 41066
+ # http://bugs.mysql.com/bug.php?id=41066
+ [ "${PV}" == "5.0.72" ] && \
+ mysql_disable_test \
+ "status2" \
+ "Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # SSL certs expired shortly after the release of 5.0.76. Affects older
+ # versions as well.
+ case ${PV} in
+ 5.0.?|5.0.[1-6]*|5.0.7[0-6])
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken in 5.0.76 due to expired certificates"
+ done
+ ;;
+ esac
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ make -j1 test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ make -j1 test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ failures=""
+ [[ $retstatus1 -eq 0 ]] || failures="test-ns"
+ [[ $retstatus2 -eq 0 ]] || failures="${failures} test-ps"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
diff --git a/profiles/package.mas b/profiles/package.mas
new file mode 100644
index 0000000..b6200d7
--- /dev/null
+++ b/profiles/package.mas
@@ -0,0 +1,4 @@
+# Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (29 Nov 2009)
+# Initial bump to mysql-5.1.41.
+# This is not ready for use yet.
+~dev-db/mysql-5.1.41