aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorg3ngr33n <gengreen@tutanota.com>2019-08-11 06:53:37 +0000
committerAnthony G. Basile <blueness@gentoo.org>2019-08-18 19:58:39 -0400
commit57a61bd634fbd53e799719d31c3d960fbf1747ce (patch)
tree63f593994355b305a598b3e2a0b6b7f026b7ad0c /x11-libs
parentmedia-libs/mesa: use patch from upstream for musl support (diff)
downloadmusl-57a61bd634fbd53e799719d31c3d960fbf1747ce.tar.gz
musl-57a61bd634fbd53e799719d31c3d960fbf1747ce.tar.bz2
musl-57a61bd634fbd53e799719d31c3d960fbf1747ce.zip
x11-libs/libva-vdpau-driver:
Bump 0.7.4-r5 - Fix headers time.h Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva-vdpau-driver/Manifest2
-rw-r--r--x11-libs/libva-vdpau-driver/files/0001-fix-headers-musl.patch10
-rw-r--r--x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild2
-rw-r--r--x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r5.ebuild49
4 files changed, 61 insertions, 2 deletions
diff --git a/x11-libs/libva-vdpau-driver/Manifest b/x11-libs/libva-vdpau-driver/Manifest
index b79becd7..3c4075e1 100644
--- a/x11-libs/libva-vdpau-driver/Manifest
+++ b/x11-libs/libva-vdpau-driver/Manifest
@@ -1 +1 @@
-DIST libva-vdpau-driver-0.7.4.tar.bz2 316729 SHA256 155c1982f0ac3f5435ba20b221bcaa11be212c37db548cd1f2a030ffa17e9bb9 SHA512 89f98dc1d7d590fb68f440dd1e37e025d64a621324e013e85dd1367681c07b09132fd2089539fc5b48934624648887a8a97539b4f07ddf9f56a8a456ad030094 WHIRLPOOL b6ba281a482dc944acff67d83d26d5a5ac7f15ea1de05c921383bdf0f6dae769d0389e6d15b607e01a8d4e18d3254f66391bbd497aa4e0eed2adbab54a13bce1
+DIST libva-vdpau-driver-0.7.4.tar.bz2 316729 BLAKE2B b9cd0bbbe1e638ad29363cd0d8c6452de222023017283ce81f138730c7ba3396f3ffca40478746cab4b93a8855e73de405aa783e44e6c1179c5e347bd7eff657 SHA512 89f98dc1d7d590fb68f440dd1e37e025d64a621324e013e85dd1367681c07b09132fd2089539fc5b48934624648887a8a97539b4f07ddf9f56a8a456ad030094
diff --git a/x11-libs/libva-vdpau-driver/files/0001-fix-headers-musl.patch b/x11-libs/libva-vdpau-driver/files/0001-fix-headers-musl.patch
new file mode 100644
index 00000000..2529fb2f
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/files/0001-fix-headers-musl.patch
@@ -0,0 +1,10 @@
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -21,6 +21,7 @@
+ #include "sysdeps.h"
+ #include "utils.h"
+ #include <time.h>
++#include <sys/time.h>
+ #include <errno.h>
+
+ #define DEBUG 1
diff --git a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild
index c7a8a2eb..cb8f67db 100644
--- a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild
+++ b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
diff --git a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r5.ebuild b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r5.ebuild
new file mode 100644
index 00000000..23e613eb
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="https://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.2.1-r1:=[X,opengl?,${MULTILIB_USEDEP}]
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ >=x11-libs/libvdpau-0.8[${MULTILIB_USEDEP}]
+ !x11-libs/vdpau-video"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glext-missing-definition.patch
+ "${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch
+ "${FILESDIR}"/${P}-libvdpau-0.8.patch
+ "${FILESDIR}"/${P}-sigfpe-crash.patch
+ "${FILESDIR}"/${P}-include-linux-videodev2.h.patch
+ "${FILESDIR}"/0001-fix-headers-musl.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable opengl glx)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}