summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/bordeaux-threads/bordeaux-threads-0.6.0.ebuild')
-rw-r--r--dev-lisp/bordeaux-threads/bordeaux-threads-0.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/bordeaux-threads/bordeaux-threads-0.6.0.ebuild b/dev-lisp/bordeaux-threads/bordeaux-threads-0.6.0.ebuild
new file mode 100644
index 00000000..05eff68c
--- /dev/null
+++ b/dev-lisp/bordeaux-threads/bordeaux-threads-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit common-lisp-2
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="A library meant to make writing portable multi-threaded apps simple."
+HOMEPAGE="http://common-lisp.net/project/bordeaux-threads/"
+SRC_URI="http://common-lisp.net/project/${PN}/releases/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+ common-lisp-install src test ${PN}.asd
+ common-lisp-symlink-asdf
+}
+
+pkg_postinst() {
+ while read line; do einfo ${line}; done <<EOF
+
+You can find API documentation on the project's wiki:
+
+ http://trac.common-lisp.net/bordeaux-threads/wiki/ApiDocumentation
+
+EOF
+}