summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-10-29 19:43:37 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:34:19 +0100
commit5d8c9fd8ecec0f21b599265c1d46abcd31d98b97 (patch)
tree5f8964628305f30cc0eae95c0579497029725adb /dev-lisp/alexandria/alexandria-20171029.ebuild
parentx11-wm/stumpwm: Adds missing dependencies (diff)
downloadlisp-5d8c9fd8ecec0f21b599265c1d46abcd31d98b97.tar.gz
lisp-5d8c9fd8ecec0f21b599265c1d46abcd31d98b97.tar.bz2
lisp-5d8c9fd8ecec0f21b599265c1d46abcd31d98b97.zip
dev-lisp/alexandria: New snapshot ebuild
Diffstat (limited to 'dev-lisp/alexandria/alexandria-20171029.ebuild')
-rw-r--r--dev-lisp/alexandria/alexandria-20171029.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lisp/alexandria/alexandria-20171029.ebuild b/dev-lisp/alexandria/alexandria-20171029.ebuild
new file mode 100644
index 00000000..c5656e8f
--- /dev/null
+++ b/dev-lisp/alexandria/alexandria-20171029.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 eutils
+
+DESCRIPTION="A collection of public domain utilities."
+HOMEPAGE="http://common-lisp.net/project/alexandria/"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.common-lisp.net/alexandria/alexandria.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( sys-apps/texinfo )"
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-fix-docstrings.patch"
+ eapply_user
+}
+
+src_compile() {
+ use doc && emake -C doc
+}
+
+src_install() {
+ common-lisp-install-sources -t all *.lisp LICENCE
+ common-lisp-install-asdf
+ dodoc README AUTHORS
+ use doc && doinfo doc/${PN}.info && dodoc doc/{"${PN}.html","${PN}.pdf"}
+}