summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-03-25 19:57:12 +0100
committerUlrich Müller <ulm@gentoo.org>2022-03-25 19:57:12 +0100
commit8aa564ce366bfc35ce90cbbb536911d1a936db3a (patch)
treec0745c783b3319edeabda72a762a8e587685a369
parentdev-lisp/gcl: Remove package (diff)
downloadlisp-8aa564ce366bfc35ce90cbbb536911d1a936db3a.tar.gz
lisp-8aa564ce366bfc35ce90cbbb536911d1a936db3a.tar.bz2
lisp-8aa564ce366bfc35ce90cbbb536911d1a936db3a.zip
dev-lisp/ecls: Remove package
Newer version in gentoo repository. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-lisp/ecls/Manifest1
-rw-r--r--dev-lisp/ecls/ecls-16.1.3.ebuild96
-rw-r--r--dev-lisp/ecls/files/README.Gentoo15
-rw-r--r--dev-lisp/ecls/files/ecls-16.1.3-build.patch10
-rw-r--r--dev-lisp/ecls/files/ecls-16.1.3-headers-gentoo.patch15
-rw-r--r--dev-lisp/ecls/metadata.xml22
6 files changed, 0 insertions, 159 deletions
diff --git a/dev-lisp/ecls/Manifest b/dev-lisp/ecls/Manifest
deleted file mode 100644
index c5eba6ed..00000000
--- a/dev-lisp/ecls/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ecl-16.1.3.tgz 7459212 BLAKE2B 4f9d6ad2bd92ede4b5b20857b95a48bad5002049e83611865d9cf13e7131adfaad147a31f22f9a3f6a2c06e46db1996aa98135c28b97bf5ef16e17b5eba0dc4b SHA512 5d743f422f6bc24671abf4c739cde8273d08f056906a1ef8aed5145c703b6d52c7fa4b5e0be8c125f32240c20ce053007786bb3ae81cc34d47791f6fae0819c1
diff --git a/dev-lisp/ecls/ecls-16.1.3.ebuild b/dev-lisp/ecls/ecls-16.1.3.ebuild
deleted file mode 100644
index c854c576..00000000
--- a/dev-lisp/ecls/ecls-16.1.3.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils multilib
-
-# test phase only works if ecls already installed #516876
-RESTRICT="test"
-
-MY_P=ecl-${PV}
-
-DESCRIPTION="ECL is an embeddable Common Lisp implementation"
-HOMEPAGE="https://common-lisp.net/project/ecl/"
-SRC_URI="https://common-lisp.net/project/ecl/static/files/release/${MY_P}.tgz"
-
-LICENSE="BSD-2 LGPL-2.1+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="cxx debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode +libatomic X"
-
-CDEPEND="dev-libs/gmp:0
- virtual/libffi
- libatomic? ( dev-libs/libatomic_ops )
- >=dev-libs/boehm-gc-7.1[threads?]
- >=dev-lisp/asdf-2.33-r3:="
-DEPEND="${CDEPEND}
- app-text/texi2html
- emacs? ( virtual/emacs >=app-eselect/eselect-emacs-1.12 )"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-PATCHES=(
- "${FILESDIR}/${P}-headers-gentoo.patch"
- "${FILESDIR}/${P}-build.patch"
-)
-
-pkg_setup () {
- if use gengc || use precisegc ; then
- ewarn "You have enabled the generational garbage collector or"
- ewarn "the precise collection routines. These features are not very stable"
- ewarn "at the moment and may cause crashes."
- ewarn "Don't enable them unless you know what you're doing."
- fi
-}
-
-src_prepare() {
- default
- cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
-}
-
-src_configure() {
- econf \
- --with-system-gmp \
- --enable-boehm=system \
- --enable-longdouble=yes \
- --with-dffi \
- $(use_with cxx) \
- $(use_enable gengc) \
- $(use_enable precisegc) \
- $(use_with debug debug-cflags) \
- $(use_enable libatomic libatomic system) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_enable threads) \
- $(use_with threads __thread) \
- $(use_enable unicode) \
- $(use_with unicode unicode-names) \
- $(use_with X x)
-}
-
-src_compile() {
- if use emacs; then
- local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
- [[ -n ${ETAGS} ]] || die "No etags implementation found"
- pushd build > /dev/null || die
- emake ETAGS=${ETAGS} TAGS
- popd > /dev/null
- else
- touch build/TAGS
- fi
-
- #parallel make fails
- emake -j1 || die "Compilation failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc README.md CHANGELOG
- dodoc "${FILESDIR}"/README.Gentoo
- pushd build/doc
- newman ecl.man ecl.1
- newman ecl-config.man ecl-config.1
- popd
-}
diff --git a/dev-lisp/ecls/files/README.Gentoo b/dev-lisp/ecls/files/README.Gentoo
deleted file mode 100644
index 9bb82f22..00000000
--- a/dev-lisp/ecls/files/README.Gentoo
+++ /dev/null
@@ -1,15 +0,0 @@
--*- outline -*-
-
-Gentoo GNU/Linux specific notes for ECL
----------------------------------------
-
-This is the README.Gentoo file from /usr/share/doc/@PF@/ directory.
-
- * The Gentoo port includes a patch to ECL's installed header file (ech.h) so
- that TRUE and FALSE are not redefined if they're already included from
- elsewhere. This makes it easier to use ECL with other software which defines
- those C preprocesser symbols (eg. glib-2.0).
-
-If you encounter any problems or have suggestions, use http://bugs.gentoo.org.
-Please don't bother the upstream authors unless you are absolutely certain it is
-not Gentoo-related.
diff --git a/dev-lisp/ecls/files/ecls-16.1.3-build.patch b/dev-lisp/ecls/files/ecls-16.1.3-build.patch
deleted file mode 100644
index ff7d6cd7..00000000
--- a/dev-lisp/ecls/files/ecls-16.1.3-build.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -r -U2 ecl-16.1.3.orig/src/c/printer/write_sse.d ecl-16.1.3/src/c/printer/write_sse.d
---- ecl-16.1.3.orig/src/c/printer/write_sse.d 2016-12-19 17:25:00.000000000 +0700
-+++ ecl-16.1.3/src/c/printer/write_sse.d 2016-12-19 19:20:01.863563607 +0700
-@@ -13,4 +13,6 @@
- */
-
-+#include <ecl/config.h>
-+
- #ifdef ECL_SSE2
- #include <ecl/ecl.h>
diff --git a/dev-lisp/ecls/files/ecls-16.1.3-headers-gentoo.patch b/dev-lisp/ecls/files/ecls-16.1.3-headers-gentoo.patch
deleted file mode 100644
index 10802aa4..00000000
--- a/dev-lisp/ecls/files/ecls-16.1.3-headers-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -r -U2 ecl-16.1.3.orig/src/h/object.h ecl-16.1.3/src/h/object.h
---- ecl-16.1.3.orig/src/h/object.h 2016-12-19 17:25:00.000000000 +0700
-+++ ecl-16.1.3/src/h/object.h 2016-12-19 19:22:21.147557750 +0700
-@@ -26,6 +26,11 @@
- */
-
-+#ifndef TRUE
- #define TRUE 1 /* boolean true value */
-+#endif
-+
-+#ifndef FALSE
- #define FALSE 0 /* boolean false value */
-+#endif
-
- #if !defined(__cplusplus) && !defined(bool)
diff --git a/dev-lisp/ecls/metadata.xml b/dev-lisp/ecls/metadata.xml
deleted file mode 100644
index 3ceb15c1..00000000
--- a/dev-lisp/ecls/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>common-lisp@gentoo.org</email>
- <name>Gentoo Common Lisp Project</name>
- </maintainer>
- <longdescription>
-ECL (Embeddable Common Lisp) is an implementation of the Common Lisp language as
-described in the X3J13 Ansi specification, featuring CLOS (Common Lisp Object
-System), conditions, loops, etc, plus a translator to C, which can produce
-standalone executables.
-</longdescription>
- <use>
- <flag name="gengc">Use generational garbage collection (experimental)</flag>
- <flag name="precisegc">Use type information during garbage collection (experimental)</flag>
- <flag name="libatomic">Use <pkg>dev-libs/libatomic_ops</pkg> library</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">ecls</remote-id>
- </upstream>
-</pkgmetadata>