summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-03-25 19:43:42 +0100
committerUlrich Müller <ulm@gentoo.org>2022-03-25 19:43:42 +0100
commit143d25808e24f5dd8a900eaef4be1a82fbf35779 (patch)
tree47a71af0e76eb7438fe3ffbfda309766574da469
parentprofiles: Remove empty app-emacs category (diff)
downloadlisp-143d25808e24f5dd8a900eaef4be1a82fbf35779.tar.gz
lisp-143d25808e24f5dd8a900eaef4be1a82fbf35779.tar.bz2
lisp-143d25808e24f5dd8a900eaef4be1a82fbf35779.zip
dev-scheme/gambit: Fix QA issues
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-scheme/gambit/gambit-4.9.3.ebuild25
-rw-r--r--dev-scheme/gambit/gambit-9999.ebuild21
2 files changed, 16 insertions, 30 deletions
diff --git a/dev-scheme/gambit/gambit-4.9.3.ebuild b/dev-scheme/gambit/gambit-4.9.3.ebuild
index 54ac8e39..28b60a83 100644
--- a/dev-scheme/gambit/gambit-4.9.3.ebuild
+++ b/dev-scheme/gambit/gambit-4.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,28 +8,21 @@ inherit elisp-common
MY_P="${PN}-v$(ver_rs 1-3 _)"
DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
-HOMEPAGE="http://gambitscheme.org/wiki/index.php/Main_Page"
-SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v$(ver_cut 1-2)/source/${MY_P}.tgz"
+HOMEPAGE="https://gambitscheme.org/wiki/index.php/Main_Page"
+SRC_URI="https://www-labs.iro.umontreal.ca/~gambit/download/gambit/v$(ver_cut 1-2)/source/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emacs ssl static"
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="emacs? ( virtual/emacs )"
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )"
SITEFILE="50gambit-gentoo.el"
-IUSE="emacs libressl ssl static"
-
-S="${WORKDIR}/${MY_P}"
-
src_configure() {
econf \
$(use_enable !static shared) \
diff --git a/dev-scheme/gambit/gambit-9999.ebuild b/dev-scheme/gambit/gambit-9999.ebuild
index 2f5153ee..1f9ee153 100644
--- a/dev-scheme/gambit/gambit-9999.ebuild
+++ b/dev-scheme/gambit/gambit-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,27 +8,20 @@ inherit autotools elisp-common git-r3
MY_P="${PN}-v$(ver_rs 1-3 _)"
DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
-HOMEPAGE="http://gambitscheme.org/wiki/index.php/Main_Page"
-#SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v$(ver_cut 1-2)/source/${MY_P}.tgz"
+HOMEPAGE="https://gambitscheme.org/wiki/index.php/Main_Page"
+#SRC_URI="https://www-labs.iro.umontreal.ca/~gambit/download/gambit/v$(ver_cut 1-2)/source/${MY_P}.tgz"
EGIT_REPO_URI="https://github.com/gambit/gambit.git"
LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
SLOT="0"
-KEYWORDS=""
+IUSE="emacs ssl static"
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="emacs? ( virtual/emacs )"
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )"
SITEFILE="50gambit-gentoo.el"
-IUSE="emacs libressl ssl static"
-
src_prepare() {
default
eautoreconf