aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-24 00:57:03 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-01-27 05:18:38 +1100
commitd6ab0dce176fe324be11bf8a470499a72f7c6052 (patch)
tree862dbd15b7d3a7a747ce619e44818ff4199aa3cd /games-puzzle
parentkde-apps/krdc: Add KF5 version (diff)
downloadkde-d6ab0dce176fe324be11bf8a470499a72f7c6052.tar.gz
kde-d6ab0dce176fe324be11bf8a470499a72f7c6052.tar.bz2
kde-d6ab0dce176fe324be11bf8a470499a72f7c6052.zip
games-puzzle/ksokoban: Add KF5 version
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ksokoban/ksokoban-9999.ebuild48
-rw-r--r--games-puzzle/ksokoban/metadata.xml8
2 files changed, 56 insertions, 0 deletions
diff --git a/games-puzzle/ksokoban/ksokoban-9999.ebuild b/games-puzzle/ksokoban/ksokoban-9999.ebuild
new file mode 100644
index 0000000000..b2eed9dc16
--- /dev/null
+++ b/games-puzzle/ksokoban/ksokoban-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_BRANCH="port-to-kf5"
+inherit kde5 eutils
+
+DESCRIPTION="The japanese warehouse keeper game"
+HOMEPAGE="https://projects.kde.org/projects/playground/games/ksokoban"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+
+DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ !games-puzzle/ksokoban:0
+"
+
+src_prepare() {
+ sed -i \
+ -e "/Exec/ s/%i.*//" \
+ "data/${PN}.desktop" || die "sed for desktop file failed"
+
+ kde5_src_prepare
+}
+
+# source lacks install target
+src_install() {
+ dobin "${BUILD_DIR}"/ksokoban
+ dodoc AUTHORS NEWS TODO
+ domenu "data/${PN}.desktop"
+ for i in 16 22 32 48 64 128; do
+ doicon -s "${i}" "data/hi${i}-app-${PN}.png"
+ done
+}
diff --git a/games-puzzle/ksokoban/metadata.xml b/games-puzzle/ksokoban/metadata.xml
new file mode 100644
index 0000000000..5f4d9f3f7c
--- /dev/null
+++ b/games-puzzle/ksokoban/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>