summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'backend/modules/gentoo_catalyst')
-rw-r--r--backend/modules/gentoo_catalyst/build.php71
-rw-r--r--backend/modules/gentoo_catalyst/catalyst.conf79
-rw-r--r--backend/modules/gentoo_catalyst/catalystrc6
3 files changed, 0 insertions, 156 deletions
diff --git a/backend/modules/gentoo_catalyst/build.php b/backend/modules/gentoo_catalyst/build.php
deleted file mode 100644
index 80746b2..0000000
--- a/backend/modules/gentoo_catalyst/build.php
+++ /dev/null
@@ -1,71 +0,0 @@
-<?php
-function gentoo_catalyst_build(&$build, &$opts, &$W) {
- global $conf, $profile;
- $profile=new sql_gentoo_profile($opts['profile']);
- $headers=$profile->get_headers();
- $arch=explode(' ', $headers['accept_keywords']);
- $arch=$arch[0];
- if (substr($arch, 0, 1) == '~')
- $arch=substr($arch, 1);
-// $C=$W.'/config_root';
- makedirs('catalyst_tmp', 'snapshot_cache');
- $catalyst=array(
- 'digests' => '',
- 'contents' => '',
- 'distdir' => '',
- // 'envscript' => '',
- 'hash_function' => 'crc32',
- 'options' => 'pkgcache metadata_overlay seedcache snapcache',
- 'portdir' => $conf['portdir'],
- 'sharedir' => '/usr/lib/catalyst', // This may not work on all systems
- 'snapshotcache' => "$W/snapshot_cache",
- 'storedir' => "$W/catalyst_tmp"
- );
- $ctc=fopen("$W/catalyst.conf", 'w');
- foreach ($catalyst as $name => $val) {
- fputs($ctc, "$name=\"$val\"\n");
- }
- fclose($ctc);
- // TODO - stages 1-3 first, only do stage4 if we have extra packages to install
- $spec=array(
- 'subarch' => $arch,
- 'version_stamp' => gmdate('Ymd-His'),
- 'target' => 'stage4',
- 'rel_type' => 'default',
- 'profile' => $headers['profile'],
- 'snapshot' => gmdate('Ymd'),
- 'source_subpath' => 'default', // FIXME
- 'portage_confdir' => '',
- 'portage_overlay' => '',
- 'pkgcache_path' => "$W/pkgcache",
- 'kerncache_path' => '',
- 'stage4/use' => $headers['use'],
- 'stage4/packages' => $opts['install_packages'],
- 'stage4/fsscript' => '',
- 'stage4/splash_theme' => '',
- 'stage4/gk_mainargs' => '',
- 'stage4/linuxrc' => '',
- 'stage4/motd' => '',
-// 'stage4/modblacklist' => '8139cp', // Not recognized by catalyst
- 'stage4/rcadd' => '',
- 'stage4/rcdel' => '',
- 'stage4/root_overlay' => '',
- 'stage4/xinitrc' => '',
- 'stage4/users' => '',
- 'boot/kernel' => '',
- 'stage4/unmerge' => '',
- 'stage4/empty' => '/var/tmp /var/cache /var/db /var/empty /var/lock /var/log /var/run /var/spool /var/state /tmp /usr/portage /usr/share/man /usr/share/info /usr/share/unimaps /usr/include /usr/share/zoneinfo /usr/share/dict /usr/share/doc /usr/share/ss /usr/share/state /usr/share/texinfo /usr/lib/python2.2 /usr/lib/portage /usr/share/gettext /usr/share/i18n /usr/share/rfc /usr/lib/X11/config /usr/lib/X11/etc /usr/lib/X11/doc /usr/src /usr/share/doc /usr/share/man /root/.ccache /etc/cron.daily /etc/cron.hourly /etc/cron.monthly /etc/cron.weekly /etc/logrotate.d /etc/rsync /usr/lib/awk /usr/lib/ccache /usr/lib/gcc-config /usr/lib/nfs /usr/local /usr/diet/include /usr/diet/man /usr/share/consolefonts/partialfonts /usr/share/consoletrans /usr/share/emacs /usr/share/gcc-data /usr/share/genkernel /etc/splash/gentoo /etc/splash/emergence /usr/share/gnuconfig /usr/share/lcms /usr/share/locale /etc/skel',
- 'stage4/rm' => '/lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf'
- );
- $specfile=fopen("$W/stage4.spec", 'w');
- foreach ($spec as $name => $val) {
- if (strlen($val))
- fputs($specfile, "$name: $val\n");
- }
- fclose($specfile);
- $pkgdir=$spec['pkgcache_path'].'/'.$spec['rel_type'].'/'.$spec['target'].'-'.$spec['version_stamp'];
- makedir(dirname($pkgdir));
- symlink($pkgdir, $profile->pkgdir);
- execute_command('Running Catalyst for build stage 4', "catalyst -c '$W/catalyst.conf' -f '$W/stage4.spec'");
-}
-?>
diff --git a/backend/modules/gentoo_catalyst/catalyst.conf b/backend/modules/gentoo_catalyst/catalyst.conf
deleted file mode 100644
index ba5505b..0000000
--- a/backend/modules/gentoo_catalyst/catalyst.conf
+++ /dev/null
@@ -1,79 +0,0 @@
-# /etc/catalyst/catalyst.conf
-
-# Simple desriptions of catalyst settings. Please refer to the online
-# documentation for more information.
-
-# Creates a .DIGESTS file containing the hash output from any of the supported
-# options below. Adding them all may take a long time.
-# Supported options: sha1, sha224, ripemd128, ripemd320, sha384, crc32,
-# ripemd256, sha256, sha512, ripemd160, md5
-digests="md5 sha1"
-
-# Creates a .CONTENTS file listing the contents of the file. Pick from any of
-# the supported options below:
-# auto - strongly recommended
-# tar-tv - does 'tar tvf FILE'
-# tar-tvz - does 'tar tvzf FILE'
-# tar-tvy - does 'tar tvyf FILE'
-# isoinfo-l - does 'isoinfo -l -i FILE'
-# isoinfo-f - does 'isoinfo -f -i FILE'
-# 'isoinfo-f' is the only option not chosen by the automatic algorithm.
-# If this variable is empty, no .CONTENTS will be generated at all.
-contents="auto"
-
-# distdir specifies where your distfiles are located. This setting should
-# work fine for most default installations.
-distdir="/usr/portage/distfiles"
-
-# envscript allows users to set options such as http proxies, MAKEOPTS,
-# GENTOO_MIRRORS, or any other environment variables needed for building.
-# The envscript file sets environment variables like so:
-# export FOO="bar"
-envscript="/etc/catalyst/catalystrc"
-
-# Internal hash function catalyst should use for things like autoresume,
-# seedcache, etc. The default and fastest is crc32. You should not ever need
-# to change this unless your OS does not support it.
-# Supported options: sha1, sha224, ripemd128, ripemd320, sha384, crc32,
-# ripemd256, sha256, sha512, ripemd160, md5
-hash_function="crc32"
-
-# options set different build-time options for catalyst. Some examples are:
-# autoresume = Attempt to resume a failed build, clear the autoresume flags with
-# the -a option to the catalyst cmdline. -p will clear the autoresume flags
-# as well as your pkgcache and kerncache
-# ( This option is not fully tested, bug reports welcome )
-# ccache = enables build time ccache support (highly recommended)
-# distcc = enable distcc support for building. You have to set distcc_hosts in
-# your spec file.
-# icecream = enables icecream compiler cluster support for building
-# kerncache = keeps a tbz2 of your built kernel and modules (useful if your
-# build stops in livecd-stage2)
-# metadata_overlay = enabled the metadata_overlay cache module in portage, which
-# uses the in-tree metadata
-# pkgcache = keeps a tbz2 of every built package (useful if your build stops
-# prematurely)
-# seedcache = use the build output of a previous target if it exists to speed up
-# the copy
-# snapcache = cache the snapshot so that it can be bind-mounted into the chroot.
-# WARNING: moving parts of the portage tree from within fsscript *will* break
-# your cache. The cache is unlinked before any empty or rm processing, though.
-#
-# (These options can be used together)
-options="autoresume kerncache metadata_overlay pkgcache seedcache snapcache"
-
-# portdir specifies the source portage tree used by the snapshot target.
-portdir="/usr/portage"
-
-# sharedir specifies where all of the catalyst runtime executables are. Most
-# users do not need to change this.
-sharedir="/usr/lib64/catalyst"
-
-# snapshot_cache specifies where the snapshots will be cached to if snapcache is
-# enabled in the options.
-snapshot_cache="/var/tmp/catalyst/snapshot_cache"
-
-# storedir specifies where catalyst will store everything that it builds, and
-# also where it will put its temporary files and caches.
-storedir="/var/tmp/catalyst"
-
diff --git a/backend/modules/gentoo_catalyst/catalystrc b/backend/modules/gentoo_catalyst/catalystrc
deleted file mode 100644
index 581772d..0000000
--- a/backend/modules/gentoo_catalyst/catalystrc
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/bash
-# This is an example catalystrc. As such, it doesn't actually *do* anything.
-
-# Uncomment the following to increase the number of threads used to compile.
-# export MAKEOPTS="-j16"
-