summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest11
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.10.1.ebuild31
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-9999.ebuild19
3 files changed, 52 insertions, 9 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
new file mode 100644
index 00000000..ebfe6f8b
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gsettings-desktop-schemas-3.10.1.tar.xz 468072 SHA256 452378c4960a145747ec69f8c6a874e5b7715454df3e2452d1ff1a0a82e76811 SHA512 42e7dc19d70c26c9ba6a7f030ea5467d9aab7ce7e4efd8a2c5bac643c354ef7a5eb02195a12f06d7615963a5fb83497437aee9ad72621ededb436cbd6a51d6a4 WHIRLPOOL f95e4c39142cb1874680aeca938e9267aa365ba593bb6f9cf654ff5769def16ca28574a35013d731e760968b20d69e635f0b5b490f95ba6f8809b834efb96780
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlKKkTMACgkQ1fmVwcYIWAY+pwCgxHvtpOPboK2R2r+2msyIIKAZ
+oTkAoJdyPus+uFpRjW4qMYwQXt7PbVZW
+=e/pl
+-----END PGP SIGNATURE-----
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.10.1.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.10.1.ebuild
new file mode 100644
index 00000000..bafd591b
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ introspection? ( >=dev-libs/gobject-introspection-1.31.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS HACKING NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-9999.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-9999.ebuild
index 44c56a22..eaeab321 100644
--- a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-9999.ebuild
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
-HOMEPAGE="http://www.gnome.org/"
+HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
LICENSE="LGPL-2.1+"
SLOT="0"
@@ -22,16 +22,17 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
fi
-RDEPEND=">=dev-libs/glib-2.31:2
- introspection? ( >=dev-libs/gobject-introspection-1.31.0 )"
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ introspection? ( >=dev-libs/gobject-introspection-1.31.0 )
+"
DEPEND="${RDEPEND}
- sys-devel/gettext
>=dev-util/intltool-0.40
- virtual/pkgconfig"
+ sys-devel/gettext
+ virtual/pkgconfig
+"
src_configure() {
- G2CONF="${G2CONF}
- $(use_enable introspection)"
DOCS="AUTHORS HACKING NEWS README"
- gnome2_src_configure
+ gnome2_src_configure $(use_enable introspection)
}