aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hal-0.5.11-patches/0026-fix-some-configure-issues.patch')
-rw-r--r--hal-0.5.11-patches/0026-fix-some-configure-issues.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/hal-0.5.11-patches/0026-fix-some-configure-issues.patch b/hal-0.5.11-patches/0026-fix-some-configure-issues.patch
new file mode 100644
index 00000000..30c683ca
--- /dev/null
+++ b/hal-0.5.11-patches/0026-fix-some-configure-issues.patch
@@ -0,0 +1,68 @@
+From f4d6db61e4c72a00640abe59c17aea5268b1b8d1 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Rafa=C5=82=20Mu=C5=BCy=C5=82o?= <galtgendo@o2.pl>
+Date: Thu, 2 Oct 2008 13:01:15 +0200
+Subject: [PATCH 26/48] fix some configure issues
+
+Fixed some configure issues.
+
+AC_ARG_ENABLE([foobar], ...) adds only --enable-foobar, The AS_HELP_STRING
+part is for help string only, so when you do i.e. AC_ARG_ENABLE([have_acpi],...)
+you create --enable-have_acpi which is not only inconsistent with the
+help string, but simply wrong, cause you check later for enable_acpi
+instead of enable_have_acpi.
+---
+ configure.in | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 112fc33..e253a8a 100644
+--- a/configure.in
++++ b/configure.in
+@@ -480,7 +480,7 @@ AC_DEFINE_UNQUOTED(DBUS_API_SUBJECT_TO_CHANGE, [], [DBUS API is subject to chang
+
+ # check for ConsoleKit
+ AM_CONDITIONAL(HAVE_CONKIT, false)
+-AC_ARG_ENABLE(console-kit, [ --enable-console-kit Use ConsoleKit],enable_console_kit=$enableval,enable_console_kit=yes)
++AC_ARG_ENABLE([console-kit], AS_HELP_STRING([--enable-console-kit], [Use ConsoleKit]), [enable_console_kit=$enableval,enable_console_kit=yes])
+ msg_conkit=no
+ if test "x$enable_console_kit" != "xno"; then
+ AM_CONDITIONAL(HAVE_CONKIT, true)
+@@ -594,7 +594,7 @@ if test "x$enable_umount_hal" != "xno"; then
+ fi
+
+ # what extra hotplug backends to use (ACPI, APM, PMU etc)
+-AC_ARG_ENABLE([have_acpi],
++AC_ARG_ENABLE([acpi],
+ AS_HELP_STRING([--disable-acpi], [Build without ACPI support]))
+ msg_acpi=no
+ if test "x$enable_acpi" != "xno"; then
+@@ -602,7 +602,7 @@ if test "x$enable_acpi" != "xno"; then
+ AC_DEFINE(HAVE_ACPI, [], [Set if we have ACPI support])
+ fi
+ AM_CONDITIONAL(HAVE_ACPI, [test x$msg_acpi = xyes], [Compiling ACPI])
+-AC_ARG_ENABLE([have_apm],
++AC_ARG_ENABLE([apm],
+ AS_HELP_STRING([--disable-apm], [Build without APM support]))
+ msg_apm=no
+ if test "x$enable_apm" != "xno"; then
+@@ -610,7 +610,7 @@ if test "x$enable_apm" != "xno"; then
+ AC_DEFINE(HAVE_APM, [], [Set if we have APM support])
+ fi
+ AM_CONDITIONAL(HAVE_APM, [test x$msg_apm = xyes], [Compiling APM])
+-AC_ARG_ENABLE([have_pmu],
++AC_ARG_ENABLE([pmu],
+ AS_HELP_STRING([--disable-pmu], [Build without PMU support]))
+ msg_pmu=no
+ if test "x$enable_pmu" != "xno"; then
+@@ -619,7 +619,7 @@ if test "x$enable_pmu" != "xno"; then
+ fi
+ AM_CONDITIONAL(HAVE_PMU, [test x$msg_pmu = xyes], [Compiling PMU])
+
+-AC_ARG_ENABLE([have_pci],
++AC_ARG_ENABLE([pci],
+ AS_HELP_STRING([--disable-pci], [Build without PCI support]))
+ msg_pci=no
+ if test "x$enable_pci" != "xno"; then
+--
+1.6.1.2
+