aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/e2fsprogs/1.47.0/e2fsprogs-1.46.0-build.patch')
-rw-r--r--patches/e2fsprogs/1.47.0/e2fsprogs-1.46.0-build.patch84
1 files changed, 84 insertions, 0 deletions
diff --git a/patches/e2fsprogs/1.47.0/e2fsprogs-1.46.0-build.patch b/patches/e2fsprogs/1.47.0/e2fsprogs-1.46.0-build.patch
new file mode 100644
index 0000000..df908b6
--- /dev/null
+++ b/patches/e2fsprogs/1.47.0/e2fsprogs-1.46.0-build.patch
@@ -0,0 +1,84 @@
+--- a/MCONFIG.in
++++ b/MCONFIG.in
+@@ -88,6 +88,7 @@ SANITIZER_LDFLAGS = @lto_ldflags@ @ubsan_ldflags@ @addrsan_ldflags@ @threadsan_l
+
+ CC = @PTHREAD_CC@
+ BUILD_CC = @BUILD_CC@
++BUILD_CFLAGS = @BUILD_CFLAGS@
+ PTHREAD_CFLAGS = @PTHREAD_CFLAGS@
+ PTHREAD_LIBS = @PTHREAD_LIBS@
+ CFLAGS = @CFLAGS@
+--- a/configure
++++ b/configure
+@@ -10399,14 +10399,12 @@ $as_echo "$as_me: WARNING:
+ esac
+ fi
+
+-
+-# See if we need a separate native compiler.
+-if test $cross_compiling = no; then
+- BUILD_CC="$CC"
+-
+-else
+- for ac_prog in gcc cc
+-do
++if test "${BUILD_CC+set}" != "set"; then
++ if test $cross_compiling = no; then
++ BUILD_CC="$CC"
++ else
++ for ac_prog in gcc cc
++ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+@@ -10447,6 +10445,16 @@ fi
+ test -n "$BUILD_CC" && break
+ done
+
++ fi
++fi
++
++if test "${BUILD_CFLAGS+set}" != "set"; then
++ if test $cross_compiling = no; then
++ BUILD_CFLAGS="$CFLAGS"
++ else
++ BUILD_CFLAGS="-g -O2"
++ fi
++
+ fi
+ for ac_header in dirent.h errno.h execinfo.h getopt.h malloc.h mntent.h paths.h semaphore.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h termio.h unistd.h utime.h attr/xattr.h linux/falloc.h linux/fd.h linux/fsmap.h linux/major.h linux/loop.h linux/types.h net/if_dl.h netinet/in.h sys/acl.h sys/disklabel.h sys/disk.h sys/file.h sys/ioctl.h sys/key.h sys/mkdev.h sys/mman.h sys/mount.h sys/prctl.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h sys/xattr.h
+ do :
+--- a/configure.ac
++++ b/configure.ac
+@@ -960,13 +960,24 @@ else
+ fi
+ AC_SUBST(MAKEINFO)
+ AC_PROG_INSTALL
+-# See if we need a separate native compiler.
+-if test $cross_compiling = no; then
+- BUILD_CC="$CC"
+- AC_SUBST(BUILD_CC)
+-else
+- AC_CHECK_PROGS(BUILD_CC, gcc cc)
++
++AC_ARG_VAR(BUILD_CC, [C compiler for build tools])
++if test "${BUILD_CC+set}" != "set"; then
++ if test $cross_compiling = no; then
++ BUILD_CC="$CC"
++ else
++ AC_CHECK_PROGS(BUILD_CC, gcc cc)
++ fi
++fi
++AC_ARG_VAR(BUILD_CFLAGS, [C compiler flags for build tools])
++if test "${BUILD_CFLAGS+set}" != "set"; then
++ if test $cross_compiling = no; then
++ BUILD_CFLAGS="$CFLAGS"
++ else
++ BUILD_CFLAGS="-g -O2"
++ fi
+ fi
++
+ AC_CHECK_HEADERS(m4_flatten([
+ dirent.h
+ errno.h
+